Mrtk-ml2-1.0.0-v1 from ML Hub flaky, no keyboard

So im trying to figure out what UI i need to standardize on in the short term because i have an application that supposed to be multiplayer from Hololens2 and Magic Leap 2.
Theres no photon or anything like that just some middle ware and websockets but 99 percent the same UI would be great.

my choices are
XRI Unity XR Interaction Toolkit.?

I tried to use MRTK3 on magic leap but didnt build
I was able to get a basic Unity Interaction Toolkit Hello world to build and run.
then i tried MRTK2 i found in the ML Hub. ( Unity® MRTK Package 1.0.0 Version 1.0 )


and it build and deployed and somewhat worked but the hand tracking was super shaky.
and the controller tracking was unusable. Keyboard wouldnt come up.
I need the keyboard for my use case.

So what should i choose then XRI? Unity XR Interaction Toolkit? Do you have some documentation on that? Also finally when is MagicLeap coming with OpenXR support in unity?

Unity Editor version:

ML2 OS version:
SDK 1.0.0 is B3E.220818.12-R.046-R.417

MLSDK version:

Host OS: (Windows/MacOS)
Windows 10

Error messages from logs (syntax-highlighting is supported via Markdown):

1 Like

We would recommend MRTK version 2 as of October, 2022.

You say the tracking for the Controller is unusable? That's very strange. First, @juan.suero.robotics , please make sure all stickers are removed from the headset and Controller, then report back?

1 Like

well i just tried
unity b11 on magic leap 2 using 3d Core template with MRTK3
installed with their install tool
and then git cloning their HandInteractionExamples from

i see the nice ray and the controller and i can select things but no grabbing works yet

let me go back and see the MRTK2 with Magic Leap

1 Like

So long story short I think i was facing issues with a project on
Unity 2022.2.0b11 , using 3D core ( not URP ), and mrtk2 ( the one from ML Hub )
this project had no hand tracking and no controller but displayed the HandInteractionExamples
no keyboard

I got MRTK3 to work as mentioned earlier
with Unity 2022.2.0b11 , using 3D core ( not URP ), and mrtk3
in this project the controller works to select things with Raycast
but cant grab, touch, no handtracking
no keyboard

finally MRTK2 worked under the following configuration
with Unity 2022.2.0b11 , URP ), and and mrtk2 ( the one from ML Hub )
full hand tracking, grabbing, but no controller
no keyboard

1 Like

@juan.suero.robotics We will need logs. I don't have enough information to troubleshoot your Controller not functioning. Is there anything in there that points to a configuration issue? Is your device on the latest OS?

1 Like

what are the things required to show the controller?
is there a controller subsystem check box i dont have checked?

yes i have the latest OS

Build: B3E.220818.12-R.046-R.417
SDK Version 29

logs attached

is there something in the MRTK i need to enable like the profile.
im using the default profile that comes with your build of the mrtk2 as provided by the ML Hub
in the MRTK3 i get form the MRTK3 github they dont use profiles anymore, its based on subsytems or something.

device_Log_20221020_0834_47.txt (871.2 KB)

1 Like

ok that was the issue. well .. that was the final issue i had other issues along the way

issue 1:
i bought the device early so did not have the latest firmware on the Magic leap
and ML hub was still having version 0.53 of the SDK while
internet resources were advising on 0.52
but now im on version 1.0 of the Magic Leap SDK

issue 2:
magic leap has not released MRTK2 build yet

issue 3:
was using 3d Core project and not the universal renderer

issue 4:
magic leaps mrtk2 ships with only handtracking profile enabled

so finally got it to work and also figured out how to get MRTK3 working on Magic Leap 2
but only the controller there works no handtracking.
ill run MRTK3 on hololens 2 and see if they have even finished the handtracking for MRTK3

1 Like

@juan.suero.robotics Sorry to hear that you ran into these problems while setting up your project. I logged your feedback so we can improve the MRTK documentation. While we update the guides, lets see if we can get all of the questions answered.

  1. Can you provide a link to the guide you were using to setup your MRTK project? The latest version of the setup instructions can be found here : MagicLeap Developer Documentation
  2. Are you looking for a sample project that is preconfigured for the Magic Leap 2 and MRTK ? Note, we currently do not provide support for MRTK v3 .
  3. Thank you for catching this issue, we will make sure to update the documentation to instruct users to use the Universal render pipeline.
  4. Please see the Interactions example scene, this scene demonstrates hand and controller input.

Note, to make sure all of the preconfigured profiles are imported correctly. Please delete the MRTK - Magic Leap 2 folder and re-import the package when upgrading package versions.

1 Like

Regarding the Keyboard -

Currently we do not support a system level keyboard. Instead, developers are encouraged to use a 3rd party solution. Please see the Unity Asset store for a few keyboard options.

1 Like

there wasnt alot available out there

and the readme at

1 Like

Thank you, we will correct the github repository description to make it more clear that the github package only supports MRTK for the Magic Leap 1, and that the MRTK support package for Magic Leap 2 needs to be downloaded via the Magic Leap Hub

1 Like