Hand Tracking -MRTK3 - hands wrong direction and seem to be missing ray casts

We are in the process of converting our application to use MRTK3 from MRTK 2.1. I have been tasked with getting it running on ML2. For some reason when putting hands into the view of the device they are flipping and scrunched in very uncomfortable ways.. I

There is also an issue with the raycast provider that should be with the hands not being there and causing a null reference in some of our code, but that can hopefully be fixed with these other issues.

Anyways just hoping to get some input here.


Unity Editor 2022.2.13:
ML2 OS 1.4.0-dev1:
MLSDK 1.10.0:
Host Windows: (Windows/MacOS)

Error messages from logs (syntax-highlighting is supported via Markdown):

@jason.odom are you using the Magic Leap MRTK integration package? Make sure that runtime configuration is enabled in the MRTK Magic Leap settings or make sure you are using the MRTK Magic Leap Rig:

Can you confirm that you are using the following guides to use MRTK on Magic Leap 2

You can also test our template project that has been preconfigured for MRTK 3 and Magic Leap:

Hi @kbabilinski, similar to @jason.odom I also have issues with the Hand Tracking in MRTK3. I started from the unity template on MRTK repo from the branch mrtk3_MagicLeap2. I have Runtime Configuration enabled and I am using MRTK XR Rig (not the MRTK Magic Leap Rig since I didn't find it anywhere).
The Hand Tracking seems to work, but not very well. The issues I observe are usually some erratic movements of the hand-rays that prevents me to manipulate objects easily, specially in the left hand-ray. Any idea?


Hi Vopaso.

Do you mind providing a video to help us understand the behavior you are seeing. Do you experience this when using the MRTK Magic Leap Template project?

The MRTK Magic Leap Rig should be located in the following directory:

Packages/Magic Leap MRTK3/Runtime/MagicLeap/Prefabs/MRTK_Variants/

Apologies for my absence. I have context switching between multiple porting projects. I had previously gone through the process of trying the Magic Leap specific XR rig replacing the one we previously had.

Today I have setup the Magic Leap MRTK Template Project but have run into an error with the spatial audio drivers. And while the documentation has a fix for the error I am getting, the fix did not work for me.

I am using Unity 2022.2.21f for this build

Do you mind providing a the logs by going to Magic Leap > Save Diagnostics Logs in the top menu. Then, to unblock your testing, remove the Spatial Audio package by going inside Unity's Package manager and uninstalling it.

Thanks @kbabilinski, I was able to put the MRTK Magic Leap Rig however it did not made any behavioral change. I realized the issue is with the built-in hand tracking feature of the ML2 because I tried it in the ML2 menu without any app and it works similar (i.e. erratical moves). Some issues I have observed are the following:

  • The rays doesn't seem to be very consistent with the actual hand pose direction
  • Sometimes the rays have jitter and are not still when they should
  • The pinch selection doesn't work all the time
  • If the hand is a little out of the scene (to be more confortable moving the hands around) the rays either disappear or increase their jitter too much preventing doing anything useful.

I hope you can improve this in a feature release. I tried this with the OS 1.4.0-dev1 and also the previous 1.3.1 release.


Thank you for that information and feedback. I have submitted your comments to our voice of customer team. We are actively working on improving our tracking algorithm and we will try to include more information about these improvements in our release newsletters as they become available.