MagicLeap2 does not boot anymore after failed update

Hello, (25.1 KB)

We have an urgent issue that needs to be solved as fast as possible for business reasons.
We bought the entreprise edition of the magic leap 2
We have been working with the Magic Leap 2 since January 2023 P/N: M90AV004_RG

Yesterday (May 11, 2023), while trying to debug with the device using the official Magic Leap Hub application, a notification asking to update the device appeared and we accepted this update with the option “erase former OS” (or equivalent) selected by default.

And then a crash happened and the update could not be completed correctly, since then, the device no longer boots correctly.

We rebooted the device, as well as the laptop, we tried other cables and another laptop but the device could no longer be detected (even adb cannot detect it).

We tried to press hold the power button for 20s and re-start but it did not fix the problem.

Actual state:

Magic Leap logo is displayed for 2s at beginning then nothing is displayed

The lights flash alternately (1+3+5 then 2+4) continuously and never stopping, like signaling an update

Firmware that MagicLeap Hub tried to install:


The device has been successfully updated April 25, 2023 through Magic Leap Hub application with the same procedure.

Here are uploaded the logs where you can see the crash.

What can be done to save the device ?

Yours truly,

Arthur Le Bourg

Hi @lebourgarthur,

Can you please send an email to Customer Care containing this information and the logs?

They will provide alternative instructions for recovery.

Hello Arthur,

Can you please provide me the Device serial number and also a good contact phone number in case we need to call you?


Magic Leap Customer Care

Hello @system,

I will send you my phone number and the device serial number through email at , I do not wish to share those information on a public forum.


Arthur Le Bourg