Device doesn't boot after updating to firmware 1.2.0-dev1

Hi Magic Leap

So I tried to update my device from 1.1 (secure) to 1.2 dev 1 (secure) and my magic leap 2 appears to have gotten bricked.

I did the update using ML Hub OS Installer, it reported success but the device itself doesn't boot up. It just stays showing the Magic Leap logo and the loading bar, that logo sometimes flashes in and out and eventually the display doesn't show anything anymore. The lights on the puck get stuck in the loading sequence.

The first time I updated I didn't factory reset, but then I tried like 4 times doing so and still no luck.

Then I reverted the flash back to 1.1 and it booted up again, tried 1.2 one last time for good measure and bricked again.

So there's a problem, any ideas?

1 Like

I flashed it to 1.2 yet again, it got stuck booting as usual, I shut it down, booted it again and 1.2.0 started up!

But then after I shut down the system and restarted it it got stuck booting and didn't work anymore.

So yeah, 1.2 doesn't work for me, I'll be on 1.1 for now.

Thank you for the update @javier. Let me check into this.

Hi @Javier, please contact us here so we can walk through the boot issues with you and your device: