Compute pack stuck in fastboot mode after OS update error "timed out while waiting for device to reboot"

ML2 OS version:
I don't remember the version number but believe it was the third option from the bottom.

Error messages from logs (syntax-highlighting is supported via Markdown):
I can't access compute pack.

Machine's operating system
Windows 10 Pro build 19045.2130.

Is device secure or unsecure
Unsecure (loaner device from early access program).

Does your compute pack get recognized by ML Hub , 'adb devices', or 'fastboot devices'?

  • ML Hub
    • No (was connecting before compute pack got stuck in fastboot mode)
  • 'adb devices'
    • No (returns empty list)
  • 'fastboot devices'
    Yes (displays serial number)

I've been stuck for a long time with hardware issues. My issues are similar to the once described in this thread Issues setting up the device - Hardware Troubleshooting - Magic Leap 2 Developer Forums

After upgrading to Oct release, the controller was "dead" and making beeping noises. I proceeded to downgrade one version at the time, when I had reached the second to the last version in the hub, the update seemed successful as I was able to pair the controller and the "controller connected" was displayed in the headset, however, there was no controller cursor similar to what's described in this post Issues setting up the device - Hardware Troubleshooting - Magic Leap 2 Developer Forums.

I then proceeded to upgrade to the next version, hoping that would fix things, but the update "timed out while waiting for device to reboot" (or similar message). This has happened several times before, but unlike before, this time the device is stuck in fastboot mode (flashing 3 LEDs followed by 2 LEDs).

I tried hard reset (hold power button for 20+ seconds) but it is still in fastboot mode when starting device.

I then proceeded to try to factory reset using adb, but the device is not returned with 'adb devices', just an empty list.

Hoping someone can advise on how I can get out of fastboot mode?

1 Like

Hi @martin.wilter,

Before we can continue, can you please make sure that it is an unsecure device using the barcode references listed in the "Secure vs. Unsecure Builds" note on this page?

1 Like

Hi @kvlasova,

I've confirmed that it's an unsecure device. P/N is M91AA000_RB.

1 Like

@martin.wilter ,

With your device connected and powered on and after cd'ing into the directory where your last attempted OS build is downloaded, can you try running fastboot continue and let us know if the update process continues?

1 Like


I used the hub to upgrade and let it download the OS build, so I'm not sure what directory that would be?

1 Like

You can find it by going to the Package Manager in ML Hub, scrolling to the ML OS version and expanding that window, then clicking the "Open Folder" link

1 Like

Thanks, @kvlasova

The 'Open folder' option was disabled regardless of which version I selected:

I assume this is because I opted to download on the demand when I upgraded.

So I went ahead and downloaded the version I believe I was updating to when the device got stuck in fastboot mode, B3E.220721.07-R.026_user.

The download location was MagicLeap/firmware/ml2 and only contained the newly downloaded B3E.220721.07-R.026_user folder.

I ran fastboot continue from both the ml2 directory and the B3E.220721.07-R.026_user directory. Both times the command returned OKAY:

but the devices did not seem to react to the command.

When I rebooted the device, it was still in fastboot mode.

1 Like

@martin.wilter "Open Folder" is disabled because it is not yet downloaded onto your machine. You will have to select Download, then "Apply" on the right when the pane comes out.

1 Like

Thanks, @sengelman. As mentioned in my previous post, I did download a build to identify the download location and then proceeded to execute the fastboot continue command from that folder as well as from the downloaded folder, but the device did not respond.

I've now downloaded all unsecure builds available and executed the fastboot continue command from the folder these folders are extracted to, but still getting the same, the command returns OKAY:

but there is no change to the device.

fastboot continue

has nothing at all to do with whichever build(s) you have downloaded.

While it's in fastboot mode, locate the file in the most recent build you have downloaded and run:

./ -e

Do not forget to include -e.

It will find your device and flash the OS. Leave the device alone during the process until you get confirmation that it is completed.


1 Like