Boot loopback, even after fastboot erase userdata and flashall_amd.bat

One of our MagicLeap Device is stucked in a boot loop.

some days ago I have updated it to the latest OS, and deployed app with new SDK to it.
I was able to test the app for some days, but this morning it stucked in a boot loop.

First I tried fastboot erase userdata; it did not helped.
Than I flashed the latest OS (1.7.0) by using flashall_amd.bat; it did not helped.
Than I tried to flash the preiously used OS version (1.5.0); it was not successfull; last 3 command has failed.
Than I flashed the latest OS (1.7.0) again; it failed on the first command.
Turned it off for a minute than tied to flash it agan; The flashing was successfull, but still stucked in boot loop;

What else can I do to make it work?

Today, the situation turned worse.
The result of flashall_amd.bat

Magic Leap Inc. (C) 2022
Welcome to flashall_amd.bat v2.1.4

NOTE: CVIP and EC are flashed by default
      Use --cvip-only to flash CVIP images only

No enumeration found. Ensure USB cable is firmly connected and double check USB enumeration in Device Manager

On Windows also an error is shown when the MagicLeap is connected via USB:

Has the device become completely useless, or can it still be brought to life?


Sorry about the trouble! If you want, you can try forcing your ML2 to boot into fastboot mode before flashing it by holding the volume-down button down when you press the power button on the compute pack. Keep holding vol-down until the device boots. If it successfully boots into fastboot mode, you'll see an alternating pattern of 3 and 2 leds on the compute pack. Once in this state, you can try running "flashall_amd.bat -e" to flash it. (-e will erase all user data similar to the fastboot erase command)

However, it's likely that there is a hardware problem with your ML2. Our customer care team can help you with this. I let them know about it. I'll send you a dm to confirm your contact details and they'll reach out to you.