What to do after a Time Out Error occurs during Magic Leap 2 OS installation

Give us as much detail as possible regarding the issue you're experiencing.

ML2 OS version:B3E.220619.07-R.124

Error messages from logs I am unable to log because I am unable to activate any Magic Leap 2 devices right now. Contacting care center now.

Let me give you a brief background.

Connect Magic Leap 2 and The Lab 2.0 and start Device Bridge.
Tap the Update Avaliable button as it appears.
WS000024

The OS update proceeded, but could not be updated because there was not enough space on the C drive of the PC. As a workaround, the OS download destination was changed to the D drive, which has sufficient capacity.
Again, I ran the update.
B3E.220619.07-R.124 to B3E.220721.07-R.027.

The update proceeds normally.

However, the reboot process takes a long time and a Time out error occurs. (The following capture is before the time out error occurred.)

Magic Leap 2 remained in Fast boot. I turned off the Magic Leap 2 at this point.

When I start up again, the red light flashes at the failure light of Magic Leap. Is it a software failure? Is it a hardware failure? I don't know. (The red light flashing is so similar that it's hard to tell the difference.)


The fan moves violently after a while as shown in the video below. (The video is not at the time of the red light.)

After this, I turned off the Magic Leap 2 by pressing the power button for more than 30 seconds while the fan was quiet; after that, when I booted up, the menu appeared, although the OS had not been upgraded. However, the tracking of the Headset and controller does not work at all and the menu is always in front of me even when I move my head. The buttons on the controller worked.

After a certain period of time, the menu disappears, and after a while, the menu appears, and so on. Perhaps a reboot is occurring periodically, but since there is nothing to indicate a startup switch, it is unclear if it is really a reboot.

I can connect to The Lab 2.0's Device Bridge in this state, but I could not exit from the Device Bridge.

Also, when using the capture function, there were times when it was possible to take pictures and other times when a message was displayed indicating that the camera was in use and the picture could not be taken.

Eventually, Magic Leap 2 was unable to boot at all. The LED does not light up when the power button is pressed. The LED does not light up when I point the power cable.

I have contacted the Care Center about the Magic Leap 2 not starting.
I do not have a ticket number as the Magic Leap care center saw my Twitter and contacted me.

What I would like to know is how you were able to avoid this situation and quickly update the Magic Leap 2 that was in a fast boot state due to a time out error during the update. Also, what are the recommended conditions for performing the update (PC specs, OS, USB cables, etc...)? If you have any recommendations for updating, please let us know.

Thanks.
Sadao Tokuyama

We have instructions on manually trying to get into Fastboot mode:

Are you able to manually get into this mode with these button combinations?

1 Like

By the way, I think manual fastboot didn't work. I'm going to try again today just to be sure, but I think it's a pretty serious situation because I plugged in the Magic Leap 2 power cable and the charging LED light doesn't even come on.

If I point the Magic Leap 2 power cable at it, the LED light comes on, right?

Let's not make assumptions until you can confirm whether or not the Fastboot steps work.

I believe I also performed Fastboot yesterday. At first I think Fastboot was working, but then I performed the subsequent operations and now the LEDs do not light up at all.

I spent over 12 hours yesterday reading through the Magic Leap Developer Portal documentation to the Care Center documentation until I made this post, doing all sorts of things and having all sorts of things happen. The result is a non-functioning Magic Leap 2 device.

I only run Fastboot because you say so, just to be sure.

@sengelman Manual Fastboot, which we have already performed several times, was requested by you, so we attempted Manual Fastboot again.
See the video below.

By the way, I got the same result when I plugged the power cable into the Magic Leap 2. This Magic Leap 2 is charging over 90% of its battery.
As I mentioned in my original post, pressing the power button on the Magic Leap 2 didn't turn on the LEDs, so I felt like I could tell right away that I couldn't do a manual Fastboot.

Please let me know if I am going about Manual Fastboot the wrong way.

Thanks.
Sadao Tokuyama

Magic Leap 2 that does not boot after attempting to boot in fast boot mode by turning on the power while holding down the volume down key at the same time.

I tried booting with fastboot as described below, but it did not boot.
WS000019

I think I am a little out of line with the intent of what I wanted to ask this question.
Let me reiterate the question I wanted to ask.

ML2 was in Fastboot state when it failed during OS update. Then, when Magic Leap 2 was powered down and Magic Leap 2 was powered up, Magic Leap 2 had a failure red light.

I need to know what action I should have taken if the OS update failed with a Time out error.

I expect that OS updates will continue to be made on a regular basis. I would like to know in advance what to do in that case.

I do not want this situation to recur.

The customer center is responding to the issue of the Magic Leap 2 not booting and the LED not lighting up.

I have already received Fastboot advice from the customer center as well.

I don't need any response on the forum about the issue of Magic Leap 2 not booting at the moment, other than how to solve the problem without fail.

Thanks.
Sadao Tokuyama

We do not have mitigation steps for this besides trying again using the OS Installer found in the Magic Leap Hub.

I received my replacement ML2 today and tried to update the OS on the ML Hub but it failed.
I got the same "Timed out waiting for device to reboot" as before. I could not do anything in this situation, so I turned off the power by pressing the power button for more than 30 seconds. After that, I plugged in the charging cable and the LED light is on. I have not done anything at this point because I don't want the device to stop booting as it did last time.

Do you have a spare computer to do the flashing with?

I also ran into a situation where the ML2 was not recognized when connected to a Windows PC, but I attempted to recover and got the ML2 into a state where it could be recognized while connected to a Windows PC.
After that, I tried to update the OS on my MacBook Pro instead of Windows PC, which I had tried to do before, and was able to update the OS successfully.
Although I was able to solve this problem, the reason why I cannot update the ML2 OS on my Windows PC is still unknown at this point.
There is a log of failed OS updates. Would it be better to post part of the log in this forum rather than in Report a Bug?

All logs you can provide us will be useful. This post will become a bug in our internal tracking system.

1 Like

I just sent the log attached to Report a Bug.

Hi @tokufxug Thanks for your patience. Are you still having this issue with Magic Leap 2 on your Windows PC?

1 Like

@kdowney Sorry for the late reply. The issue of not being able to update ML2 OS on Windows has not been resolved. We are now using a Mac to perform ML2 OS updates; we will not perform ML2 OS updates on Windows because even one failure could cause the ML2 to fail.Since there is no recovery function for ML2 OS update failure, a recovery function for ML2 OS update failure is needed.

1 Like

Thanks very much @tokufxug, I spoke to our Customer Care engineers just now and they are standing by to help. May I ask you to contact Customer Care here? I would do it for you but I wouldn't know your info. The engineers are ready for your message.

1 Like

@kdowney I am in the process of successfully updating ML2 OS on my Mac. Previously, when I performed the ML2 OS update on Windows, ML2 completely stopped booting. I contacted Customer Center to replace ML2. I tried to perform ML2 OS update on the replaced ML2 with Windows, but it failed, so I performed ML2 OS update on Mac.

Since updating ML2 OS on Windows always fails, or worse, causes ML2 to malfunction, it was my decision not to implement ML2 OS updates on Windows in the future.

The problem of not being able to update ML2 OS on Windows has not been resolved, but updating ML2 OS itself is not a problem for me, as it is possible on a Mac.