Compute Hardware Failure

I have been developing for the ML2 for a while now but today the device with OS version 1.6.0 will no longer boot up. After pressing the power button it shows the first two white LEDs and then starts blinking the 3 red LEDs to the right. According to your LED guide it is some kind of compute hardware failure.

The device worked yesterday when I ended my day with turning the device off and putting it on my desk to charge over night. I remember seeing this error a couple of months before but it resolved itself after a while.

I don't think I can get any more information from the device. It is not recognized by adb devices command or Magic Leap Hub. Trying to turn it on by holding down the fastboot buttons resulted in the same error.

Any idea how I can get it working again?


Hi Erich,

Sorry about the trouble! Our customer care team should be able to help you with this issue. I'll send you a dm. I can give your contact info to them and they'll reach out to you.