Magic leap no longer responding (3 flashing center lights) after initial update

Hi all,
I received the magic leap this last week and upon the very first update it no longer boots properly. The initial update failed and now whenever I boot it, I can see the screen slightly illuminate but nothing shows up. Additionally it does not show up on ADB anymore. Full story below:

Device product number: M90AA004_RC

ML2 OS version:
Started on B3E.220619.07-R.124, tried updating to

I first got the headset and on first boot got everything set up. I read that in order to use it in unity I needed to update to the B3E.220721.07-R.026_user_secure OS. When I launched the Lab 2 on my Macbook Pro M2 Monterey and went through the download and install process.

The install process failed during installation, while I was not able to capture exactly what it had said, I did retrieve the following logs from The Lab 2 logs app:

2022-08-22 18:14:49.204 INFO  OSGILogListener: Session 2022-08-22 18:14:45.598                                               
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US
Framework arguments: -keyring /Users/<me!>/.eclipse_keyring
Command-line arguments: -os macosx -ws cocoa -arch x86_64 -keyring /Users/<me!>/.eclipse_keyring

2022-08-22 18:14:55.574 WARN  FileSystemBasedResourceProvider: No subcategories, failed to download packages?
2022-08-22 18:22:36.469 ERROR FirmwareInstallationVMImpl: Failed to run './ -s G762XT000026 -e' (exit code: 1).
2022-08-22 18:24:48.039 ERROR core: com.magicleap.common.core - Installation failed: Failed to run './ -s G762XT000026 -e' (exit code: 1).```

After this, I could no longer connect my magic leap to the computer and get it to show up on ADB and the screen was illluminated but has no content.

I followed the forum posts and ML2 guide (

I got it into the recovery mode (e.g. 3 flashing center lights) and I was able to run `lusb`. The following output confirmed it was still connected:

Sams-MBP B3E.220721.07-R.026_user_secure % lsusb
Bus 001 Device 001: ID 2109:0100 VIA Labs, Inc. USB 2.0 BILLBOARD Serial: 0000000000000001
Bus 002 Device 001: ID 0438:0100 Advanced Micro Devices DFU RECOVERY Serial: 53CD59F42A37D9BA
Bus 000 Device 000: ID 2109:0100 VIA Labs, Inc. USB 3.1 Bus
Bus 000 Device 000: ID 0438:0100 Advanced Micro Devices USB 3.1 Bus
Bus 000 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub ```

However, when I try to run the recovery mode flashing script ./ -r, it does not do anything and shows the following:

@Sams-MBP B3E.220721.07-R.026_user_secure % ./ -r

Magic Leap flashall_amd script 2.1.4

Note: CVIP and EC are flashed by default
      Use --cvip-only to flash only cvip images

No devices detected! Check enumeration and try again!```

It looks like I was not able to get it into the right state. Also when I go to get it into recovery mode, as soon as I press volume up and power while plugged into my computer, it immediately goes to the flashing red center 3 lights.

Any advice on how to proceed?
1 Like

@nanoSam , thank you for reporting. Follow the steps starting here:

You want to get into fastboot mode and flash from there. Let us know how it goes?

1 Like

(Unrelated, I noticed on your syntax-highlighting, your closing backticks should be placed on a newline before terminating — just a friendly observation)


@nanosam, any luck with the steps we outlined?


I ended up switching to my Windows PC instead of Macbook M1 since the python commands just werent working (./ -r). It worked right away for Windows :confused:

1 Like

Did your machine successfully flash via Windows?

1 Like