RenderDoc doesnt see android device

As titled. Only local context is visible. Using version 1.9 provided by the lab.
I'm not sure how to pad this out to 100 letters with out adding superfluous information.

1 Like

Hi Luke, I want to make sure your SDK is configured correctly. The best way to do that is to have The Magic Leap Hub installed, if you don't already. It's replaced The Lab as our hub that lets you install and manage Magic Leap tools.

1 Like

Yes, I have Installed the "ML Hub", and I am on the latest OS. Renderdoc still sees no android device when the ML2 is plugged into the computer.

1 Like

Hey Luke, just a few things that come to mind for this.

  1. The ML Hub is having no issue detecting the device if you use the device bridge correct? If the device isn't detected by device bridge then I would continue to the next set of thoughts.
  2. When the device is on and you plug it into the computer do you see a popup in the headset that asks something about "do you want to allow access to debug?". When you see this popup make sure to say yes and that may have been the issue.
  3. I have seen instances where usb 2.0 and usb 3.0 ports have different results. In my experience I had better luck using a usb 2.0 port when connecting the device to my computer.

I figured it out from the renderdoc diagnostic log - it wasnt able to find adb, even though I setup the sdk paths, so I tried another copy of the sdk and it worked.