ML2 keeps disconnecting from Device Bridge every couple of seconds


The headset itself works fine but when I want to inspect it via device bridge (USB cable 3.1 A -> USB C) it keeps losing/ disconnecting the device and the loop starts over.

Hi @NomtekDev thank you for your post and welcome to the Magic Leap forum. You'd need a USB-C to USB-C connection, or connect over wifi.

Hi Kevin. First of all I appreciate your quick reply - thanks!

Can I ask you to shed more light on why usb c <-> usb c connection is mandatory? It's just a plug isn't it? If my MOBO is supporting USB 3.1 gen 2 on its end it should support all devices, ML2 included right?

Also, on top of that I have tested the wifi bridge - same results. I have cleared all Unity and ADB instances, reinstalled all of the sofware and the problem remains. The device bridge works fine on my laptop

Hi @NomtekDev Our Customer Care team will reach out to you shortly to troubleshoot. We recommend USB-C to USB-C to connect to the ML2 as a best practice, but there's different steps our Care team can try to ID the issue. Thanks for surfacing.

Hi NomtekDev,

I'm Jack with Magic Leap and Kevin sent your request my way since it seems to be a possible hardware issue. I do have a few questions for you - What version of the Hub are you using? Make sure you are not using the Magic Leap Lab software as that is only for Magic Leap 1. Did the device bridge ever work before now or has it never worked for you? When you go into the headset, does it prompt you to enable USB-debugging on the main display? Correct me if I'm wrong, but you're using the USB A to C cable because you dont have an available type C port on your computer, right? If the mobo supports 3.1gen 2 then you should be fine, but it's also possible that there's something wrong with the cable. Can you test it in a known good configuration to rule out the cable?

Thank you,

Hi Jack,

I'm not exactly sure how to check the Hub version - it's the 1.2.0-dev2 sdk and the hub was downloaded last week. It's definitely not the ML Lab.
The device bridge has never properly worked on my desktop, it does however work on my laptop.
The headset propmpted me for USB debugging and I confirmed.
You got the cable situation exactly right - I have tested the USB A -> USB C cable on a laptop (which works with the headset anyways) and it was fine.
My laptop has no problem supporting the following : USB C - C , wifi bridge, USB A - C.

Thank you

Hi @jspire , @kdowney

I would appreciate a follow up.

Thank you


In the menu for Hub there's an option "About" which is available when you first launch the Hub on the landing page with all the activity cards. Also from any menu if you select "Save Diagnostic Logs...". This will generate a zip file which has logs from both the device and the Hub to help debug this problem. If you can provide those we can look a little bit further.


@kpiascik , @jspire I would like to send it to you via a private message but I don't suppose this website supports it. Would you mind sharing your email or an alternative channel?

Hi @NomtekDev, you can send it to Thanks very much.

Received, thank you.

Thanks @NomtekDev. I see you're using Unity and it can have a conflicting adb. I see some evidence in the logs you sent, but can’t be exactly sure.

Please try these steps here to make sure there isn't a conflict: MagicLeap Developer Documentation

Please let me know if this unblocks you.

Hi NomtekDev,

I just wanted to follow up on this and see if you still required assistance from us. No response is required if your issue is resolved. We will close the ticket if we do not hear back from you after some time.

Thank you,