Installation of ML toole etc for latest version of Unity - errors!

HI

Having tried to install and integrate ML tools etc with Unity I have found many errors in the documented process. I have tried multiple options on intel macs and silicon macs. Having carefully followed instructions I'm beginning to wonder if the installation notes are now out of sync with the tools that need to be downloaded. I'm happy to accept it could be me but it need a different process.

I would prefer to use the version of OpenXR that allows most of the ML features to be accessed by the programmer.

Cheers

Roy

Do you mind providing more information on the errors you are finding and information about the reproduction steps?

Hi,

I’ll gather a few details to explain what is happening.

Cheers

Roy

On 16 May 2024, at 19:47, Magic Leap Care care@magicleap.com wrote:

Magic Leap Unity SDK** THIS MESSAGE ORIGINATED OUTSIDE LOUGHBOROUGH UNIVERSITY **

** Be wary of links or attachments, especially if the email is unsolicited or you don't recognise the sender's email address. **

Hi

Some details:

Procedure followed:

My goal is: Unity Magic Leap OpenXR Workflow

Following procedure:

https://developer-docs.magicleap.cloud/docs/guides/unity/getting-started/install-the-tools/#

Everything goes ok until:

If you are unsure which SDK path is used by your Unity installation, you can view the Android SDK path used by the Unity Editor inside Unity's Preferences Window.

  1. In Unity, select Edit > Preferences (macOS: Unity > Preferences).

In the mac version - macOS: Unity > Preferences) does not exist

Things stop working at this point:

![A screenshot of a software menu

Description automatically generated.png](cid:13D046C3-88F4-4795-BFAC-549A2EB23A8F)

It seems Magic Leap Unity SDK does not download or is incompatible with the M2 Mac

Interestingly following exactly the same process on an intel Mac things get further ahead but everthing stops installing at the point where the installatiuon is looking for the SDK?

Cheers

Roy

I see that some images did not transfer properly. Could you also clarity what you mean by the following?

everthing stops installing at the point where the installatiuon is looking for the SDK?

Additionally, you are using the incorrect getting started guide. Please use the guide in the OpenXR section instead :

Hi

Thank you for the correct getting started guide - I have managed to get through to the point ‘Build settings;

  1. In the menu, go to File and select Build Settings.
  2. Under Platform, select Android.
  3. Click Switch Platform.
  4. You are now ready to add scenes to the build order and build to the device!

I could not find ’Switch Platform” ?

I went through the validation process without errors.

Then moving onto:

‘Building a simple App with OpenXR. - Creating a scene.

When selecting File > New scene and selecting the basic scene I get an error:

Couldn't parse HID descriptor with fast parser. Using fallback
UnityEngine.InputSystem.LowLevel.NativeInputRuntime/<>c__DisplayClass7_0:<set_onUpdate>b__0 (UnityEngineInternal.Input.NativeInputUpdateType,UnityEngineInternal.Input.NativeInputEventBuffer*)
UnityEngineInternal.Input.NativeInputSystem:NotifyUpdate (UnityEngineInternal.Input.NativeInputUpdateType,intptr) (at

I could not find the ML Rig prefab etc.

BTW - When attempting to install on another identical Mac asking for the location of the magic keep sdk which could not be found - all very odd.

Cheese

Roy

If you are new to Unity. I recommend using the Magic Leap Examples project that can be downloaded form that Magic Leap Hub instead. Or using the MRTK 3 Template project.

  1. Switch platform appears if you select a platform that is not active. A Unity icon appears next to the active build target. However if you select another platform you will see the button. In this sample I am already targeting Android but if I select Dedicated Server the button appears. So it might be that your editor is already set for Android

  1. The rig is included as part of the Magic Leap Rig and Inputs sample and has to be imported via the package manager as listed in the prerequisite section of the document.

HI

Yes - I am new to Unity having written everything in the past in C or Unreal. I do need to use OpenXR for other reasons and I don’t mind learning Unity.

Before getting stuck into my own code I thought it expedient to try using the setup example and the ML setup options seemed like a good idea.

So any advice you can give will be most welcome.

Cheers

Roy

Note: The MRTK 3 Template project and the Unity Example Project both use OpenXR.

On the mac, have you installed the Magic Leap SDK and the Magic Leap Unity Package through the Magic Leap Hub?