Keyboard example scene setup - build error + missing scripts?

I have the keyboard example open yet the keyboard and the controller are missing scripts, what is needed to complete this sample scene setup? thanks

and there is now a build error after importing the keyboard example

1 Like

Hi @johnhanacek I need a little more information about this. What version of the SDK and OS are you using? Have you checked the Unity Examples project for Keyboard usage? Was this from that project or the Keyboard example downloaded elsewhere?

@johnhanacek Any luck?

Closing this thread due to inactivity. Thanks for stopping by the Magic Leap 2 Forum.

Hi I'm having this same issue. Downloaded Keyboard package from zip file linked in the developer forum. Installed package from disk. Console prints two errors of "Platform name 'Relish' not supported." Is it possible to re-open this thread or should I start a new one?

I'm working off of a modified version of the Magic Leap eye tracking example scene. I've installed the latest version of the setup utility and am all green on it.

Unity 2022.2.1f1
ML OS 1.2.0-dev2
ML Unity SDK 1.5.0

Hi @rzahreddine please use the new keyboard package here: GitHub - magicleap/MagicLeapXRKeyboard: A keyboard that can be used in any project that supports Unity's XR Interaction Toolkit.

You can download the repository to check out the example scene, or grab the package located in Packages/MagicleapXRKeyboard

Hi @ababilinski, thanks for pointing me to the new repo. Unfortunately when I import the package it causes Unity to crash when I attempt to build the scene. Upon loading the package I get the following window:
I have tried both options and it still crashes when I try to build and run. I can send you the Unity crash logs if that will be helpful?

In case its a potentially helpful clue: This process appears to have also broken something with how the Game Controller in XR Rig prefab connects to the rendered ray. When I first load a scene the ray fails to "attach" to the controller and is just stuck in its initialization position. If I hit the menu button and then re-enter the already running app then the ray re-connects to the controller as expected. I've also been able to create a situation where I load a scene and have both a correctly functioning ray and a stuck ray. None of these issues were present prior to attempting to work with the new keyboard package.

How are you importing the package into your project?

Please do the following:

  1. Configure your project using the Magic Leap Setup Tool.
  2. Unzip (3.0 MB) and import the .uniypackage file

Hi @ababilinski ,

Apologies for the delayed reply I was on vacation last week.

I have tried both importing the package through the package manger as well as going to Assets>Import Package>CustomPackage... and importing the package you just linked to me. I get the same result in either case.

I was able to export my scenes with the "corrupted" interaction layers as a package and import them into an unaltered version of the Magic Leap Examples project. From there I was then able to utilize the ML Virtual Keyboard Prefab provided in that project. That will work for me for now, but I'd still like to use and explore the expanded keyboard shown in your package. Thanks for your help!