Have to turn on WiFi-bridge every boot

It's great you can deploy via cable and WiFi. Unfortunately, according to the documentation, the WiFi bridge is always turned off at boot time and can only be turned on via the device bridge, when you connect the device to your computer by cable:

This almost completely defies the purpose, because if you connect by cable, you might as well deploy by cable. Why not do as HoloLens? Turn it on, it stays on, even after multiple boot times, until you turn it off. Yeah, drive-by-attacks and stuff, I know. But see, if a bad actor already has access to my home or corp network, I am hosed anyway.

Magic Leap 2 uses standard Android ADB protocol to connect to your device over Wi-Fi and over a USB connection. The issue you are seeing is a limitation of ADB over Wi-Fi.

Note, Wi-Fi Debugging is not the same as ADB over Wi-Fi. That said, I will share your feedback with our voice of customer team.

I know it's not the same, I am simply talking about being able to deploy stuff. It would be very helpful if I could just enable this from the settings menu inside the headset

1 Like

One thing, if your IP on the device stays the same you should be able to reconnect to the device even after the device reboots. We are working on some UI improvements to make the ability to connect more apparent.

My word, you are right. I kind of assumed the Hub would reconnect to the device automatically - just like it does when you are cable connected - but you have explicitly click "connect". Also, I think I am suffering from ADB version woes, depending on what kind of Unity I use sometimes the connection to the device just drops after using playmode. Until, I found out yesterday, I go to the task manager and explicitly kill all ADB processes.

My comment that it's weird you can only turn on WiFi connection using a cable connection stands :). Thanks for you help in this

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.