Installation Failed 1.4.1(secure)

Hello guys,

I want to update my Magic Leap 2 Device from 1.4.0-dev2(secure) to 1.4.1(secure).
However after I try to install the new OS it says Installation Failed.

It starts like this ...


followed by ...


I also receive these Output Details:

Rebooting device into FASTBOOT mode
adb reboot bootloader failed.
Installation failed: adb reboot bootloader failed.
Rebooting device...

I tried...

  • using different cable
  • using different port
  • using different OS-version

and I get the same error.
Additionally I created bugreport and MLHubLogs if needed.

I appreciate any help.

Hi Batu,

Sorry for the trouble. Let's see if we can troubleshoot- are you able to connect to your ML2 at all using adb? (Android Debug Bridge (adb)  |  Android Studio  |  Android Developers) If you run 'adb devices' from a shell window with your ML2 connected via usb, you should see output like this-

List of devices attached
[serial number]   device

Additionally, you should be able to see information about your device in the 'Device Bridge' page in ML Hub when it is connected.

In order to send adb commands to the device and for ML Hub functionality to work properly, you need to allow connections from the connected pc. When the device is first connected to your PC, you should see a prompt in the ML2 display asking to allow connections.

From the ML2 home menu, if you select Settings -> Connected Devices -> USB
"Use USB for" should be set to
"File Transfer / ML Hub Connectivity"

If you continue to have issues updating the OS, then I would recommend reaching out to our customer care team and they can help you troubleshoot further and manually flash the OS image if needed-


I just checked if the points from above work (run adb devices and checked ML2 settings). I see the device in the console and have had the right box ticked in the ML2 settings.

However I noticed, after ticking the following box:

"Always allow from this computer", the update was successful.

No clue if there are any correlations but now it works for the least. :slight_smile:
Thank you very much!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.