Application crashes on startup on device

App crashes on startup.

I can build my app, and when I patch the application appears on the ML2. But the app crashes instantly on startup.

I followed the getting started steps of the documentation for both openXR and MLSDK but they both don't seem to work.

I tried project setup manually and with the setup tool but both fail.

The weird thing is that when using the examples for openXR and adding the setup tool, it does work to run it on the ML2.

A few months ago I made another MLSDK project in version 2.1.0 and this does also work on the ML2.

It appears that new projects that I create don't work.

The device log shows a dereference of a null pointer, but the only thing i did was the project setup and adding the cube.

Thanks in advance.

Unity Editor version: 2022.3.35f1
ML2 OS version: 1.7.0
Unity SDK version: 2.2.0
Host OS: Windows 11

Error messages from logs (syntax-highlighting is supported via Markdown):
device_Log_20240708_1404_26.txt (95.6 KB)

This may be an issue related to one of your Unity packages being out of date. Check out your Unity XR Hands package version. What version is your project using versus the example?

Best,

El

I fixed it yesterday, using the registry to download to import the magic leap sdk fixed this. (The project does not contain the XRhands package, though , it still works)

However I still can't create a project with mlsdk 1.12, but i need it to test stuff faster.
device_Log_20240708_1524_53.txt (43.9 KB)

This is the log I get when using version 1.12.It says fault address but can't seem to understand why.
I can run my project without problems in the app sim.
Currently I am solving this by using the example package and clearing this out to put my project in.

Thx for the help guys!