MLHub / AppSim crashes when trying to start target connection

When trying to connect to a target (device or simulator) ML2 hub crashes instantly without an error.

I tried setting Hub > Settings > Developer > Custom adb: Pointing to Unity, Hub > Settings > Developer: Android Studio but ML hub still crashes.

Thanks for the support!

Give us as much detail as possible regarding the issue you're experiencing.

Unity Editor version (if applicable):
ML2 OS version: 1.5.0
MLSDK version: 1.5.0
ML Hub version: 2.0.0
Magic Leap Application Simulator (ZI) Runtime version: 3.8.0
Magic Leap App Simulator for Unity (if applicable): 3.8.0
Host OS: Windows x64

Please do not submit without first getting a ZIP of your logs from:

https://developer-docs.magicleap.cloud/docs/guides/developer-tools/ml-hub/app-sim/error-reporting

Logs:
MLHubLogs-20240211-194933-win.zip (9.5 MB)

Do you mind trying to connect to the Magic Leap Simulator directly through the Magic Leap Hub rather than using the Magic Leap App Simulator for Unity package?

Hi, thanks for the response.

I am not using the unity package com.magicleap.zifunity, I am using the Magic leap simulator directly through the magic leap hub when this error occurs.

The package is not installed.

My issue is arises outside of unity. Here to reproduce

  1. start ML Hub
  2. connect device via usb
  3. on device, allow to connect to pc
  4. start application simulator (through ml hub)
  5. chose target > device
  6. when clicking start, MLHub crashes

Thank you for the detailed reproduction steps. One more question, are you using the Magic Leap XR provider or OpenXR? Can you verify that the OpenXR provider is disabled in both the standalone and Android tab ?

Currently the OpenXR workflow is not supported when using the Application Simulator. That said, it should not result in a crash.

Thanks, I am currently on leave and can test with the device on 26.2. again.
I just checked the settings and OpenXR is not selected in either standalone or android. The unity project uses the MagicLeapXR provider

I tried to ship an application before going on a leave, but still could not get the simulator running. Yesterday, I tried to track down the problem and here are some insights:

Platform: Windows x64:

  1. Run ml_hubc.exe /k
  2. I see that starting the application simulator then invokes this: CommandExecutor: Invoking: C:/Users/danie/MagicLeap/tools/zi/v3.8.0.20231208/bin/VDCLI.exe -V1 --opengl-status soon after which the ml hub crashes
  3. I tried to run mlvdsetup.bat /k and envsetup.bat /k manually.

From envsetup.bat i get the following output:

*** Setting MLSDK=C:\Users\danie\MagicLeap\mlsdk\v1.5.0 and updating PATH
*** ANDROID_HOME is not set, checking default paths...
*** Setting ANDROID_HOME=C:\Users\danie\AppData\Local\Android\sdk
*** ANDROID_NDK_ROOT is not set, checking default paths...
File Not Found

Which might indicate that the ndk root is not discovering the Unity NDK that was installed with Unity. It looks like the envsetup.bat is unable the NDK that is existing and installed through Unity.

This might be the cause, but I am not sure. I will be able to provide more insights and test the application again on Feb 26th. Thanks for your ongoing support.

@footballdaniel Please try starting App Sim simulator mode (namely choose "Target > Simulator") in the Hub, and see if it crashes. If it does, please collect and post the log zip file again.