When wearing Glasses, ML1 and ML2 auto-shut down

When using our ML2, we updated to 1.2.0. With that update, when a user is wearing glasses, the device automatically shuts off. This was not a "feature" before that.

We did notice the same thing when we recently updated our ML1.

To fix it, we turned off the Compute Pack Standby under the Battery option.

This may be a bigger issue if other people are wearing glasses, or if our off-site users are wearing glasses and do not understand the Standby Mode will fix this.

Plus we lose standby mode for all glasses users.

My question is, was this done on purpose, simple oversight, and should we prepare our users to turn off the Standby Mode if they wear glasses?

Thanks!
Andrew

@andrewg Thank your for this feedback. I have sent it in and taken your feedback that the default behavior of Standby is too invasive for your needs. While this gets evaluated, the workaround would be to manually disable Standby.

To answer your question, this level of Standby diligence is part of a Product requirement that was recently implemented, but will now likely be re-evaluated.

If I may offer a suggestion: implementing an "enter standby mode" or "sleep" button in the menu system could help so that this can be triggered on demand. The ML1 does have a "sleep" button that is lacking on the ML2.

Hi Andrew,

Our engineering team recommends that you disable the Standby state if you want the device to be "always on"
I will relay your feature suggestion to them as well.

Thank you,

Hi Andrew,

They also suggest using Android WakeLock to block the automatic Standby power state transition. You can use this feature to implement a switch within their app to block the automatic Standby power state transition.

Thank you,

Hi Andrew,

Do you still require help with this issue or are you okay with us closing it at this time?

Thank you,