Spatial Mapping permission doesn't exist

When I build and run the Native example of meshing that comes with samples and try to run it on the ML2, it asks for SPATILA_MAPPING permission to be granted, however, I can not seem to grant this permission, as it doesn't exist on the permission manager list, I also listed all the available permissions from adb, and there was no SPATIAL_MAPPING permission

also the C-API samples Overview
Here doesn't list the meshing example

1 Like

Hi ,

The C Samples page will be updated shortly. What SDK and OS are you running?

1 Like

In July 2022 release we had this change:

  • com.magicleap.permission.WORLD_RECONSTRUCTION permission was renamed to com.magicleap.permission.SPATIAL_MAPPING and protection level was updated from normal to dangerous.

See release notes:

So it can be a mismatch b/w OS and SDK. I'd recommend to update both SDK and OS to the latest.

1 Like

Thanks for your answer,
I tried to update the OS however, it seems to require USB-cable connection to the hub according to this
Troubleshooting Your Hub - Computer Connection – Care | Magic Leap

Of course, I tried just connect it to my USB-C port and it treats it as a charger (incompatible charger)

so I am asking here how to update it wirelessly (if possible)
Update magic leap wirelessly - Getting Started - Magic Leap 2 Developer Forums

1 Like

Using the included USB-C cable that came with the unit will allow you to update via a direct USB connection. This is the only method of update we will recommend.

1 Like

I contacted my supervisor regarding this, but he said he didn't receive anything with the model, he received model + the controller + the case.

Is there anything special about the cable? I am ready to buy one. it might be possible that I am missing something on my machine, is the a forum that talks about the process of connecting via usb if out of the box connection doesn't work?

1 Like

It is a USB-C cable that can provide power AND data. If you get a message regarding an incompatible or insufficient charger, that's just because the wattage supplied is less than what can be provided over a data connection to a computer versus a power supply.

Please read through our documentation as you're getting started.

1 Like