ML Hub Internet Connectivity Failure

Hi All - I have just acquired a new Dell laptop and cannot get ML Hub to connect to the internet to download new packages. I have tried all the standard troubleshooting but cannot get it to connect and had previously been running ML on my prior laptop no issues. Any guidance would be appreciated.

Trouble shooting tried includes:
Reset laptop to factory default
Uninstall and reinstall ML Hub 5x
Run as admin
3 different wifi networks (work 1, work-guest 2, and home network 3)
Activated and deactivated all firewall protections to ensure no unintended blocking of connections

Hi @dompaolino,

Welcome to the Magic Leap 2 Developer Forums. We are so grateful to have you here engaging with us.

Are you receiving any errors from the ML Hub? Are the download just not starting?



I'm having the same issue. This is specifically happening with the Package Manager but there are symptoms of the same problem in the Hub itself (see image):

The specific issue with the Package Manager is captured here:

The entire application locks up for about a minute before this dialog appears.

A few details, the Hub works fine on my personal computer. My work computer which is connected to the same network is experiencing this problem. It is connected via VPN and behind a proxy which is where I'd imagine the problem is. The system environment variables for the proxy are set. I've also created a .cmd script to launch the Hub with the proxy settings enabled with no luck.

Any help you can provide will be most appreciated.

I had those same issues (in your screenshots) with the ML Hub. During my testing, I had 3 laptops side by side. Dell Work Laptop A, Dell Work Laptop B (both had the same device-management package but different Dell models) and my personal 2023 Mac Book pro.

On Work Laptop A (WLA) and the Mac I was able to run the ML hub with no issues, but WLB was having the failure. I reset to stock, reloaded everything, turned off firewall, and just about everything under the sun but could not get WLB to connect to the internet within ML Hub. I ultimately swapped out the Dell for an MSI and was up and running successfully in 30 minutes. The issue remained unsolved for me, but accomplished my task anyway. (Worth noting, this was the only ML Hub issue i've had using it for almost 2 years)

What version of the ML Hub are you using? @dompaolino

Can you please provide diagnostic logs from the ML Hub?
Are your Windows root certificates up to date?