Device Stream and Advance Capture crash on startup after update

I just updated my Magic Leap Hub and I am now no longer able to do a device stream or an Advance Capture. I had to update it so that i can run the App Simulator but was running device stream the last few days with no issues.

When i select Device Stream, it says "Respond to authorization" and then immediately shuts down the entire application.

When i select Advanced Capture it says "Respond to authorization" and then immediately shuts down the entire application.

Do you have a download to the previous version? I need to do some recordings this week. Or do you have any ways I can troubleshoot this easily? I tried turning it off and turning it back on. I uninstalled the entire MLHub and reinstalled a fresh copy. I tried rolling back Runtimes for the App simulator. I also restarted my Mac and tried again with the same auto-shutdown.

ML2 OS version: 1.5.0
MLSDK version:
ML Hub version:
Magic Leap Application Simulator (ZI) Runtime version:
Magic Leap App Simulator for Unity (if applicable):
Host OS: (Windows/MacOS)

Please do not submit without first getting a ZIP of your logs from:

Don't forget to attach the logs! (194.9 KB)

Does the device show as unauthorized when trying to enter device bridge or does it occur only when using Device Stream and Capture?

Can you make sure Device Stream is enabled on your Magic Leap 2? Settings> System > Capture and Device Stream

Are you connecting to Device Stream over Wifi or using Usb?

When you are referring to "shuts down the entire application" are you referring to the prompt hiding on your device or the Magic Leap Hub shutting down?

No it does not show "unauthroized" when trying to enter device bridge. I'm still able to connect through usb and wifi to send my builds to the machine.

Yes, the Capture and Device Stream is enabled

I tried both Device Stream over WiFi and usb to rule out any network issues.

When i say shut down the entire application: The Magic Leap Hub spins and then fully crashes/shuts down. Not the Magic Leap device, that is fine.

I am on my home machine today and did not update my magic leap hub. It is working just fine on this one. I can update you tomorrow as to if my office machine with the latest version of Magic Leap Hub is still not working.

this is my current version at home:

Magic Leap HubVersion
Magic Leap Application Simulator Module Version
Magic Leap Application Simulator Runtime Version
Server: 3.8 (built Dec  8 2023), Protocol: 27
ZIF (bundled): Version
ZIF (runtime): Version

I'll paste the MLH version that is not working in my office when i get in tomorrow am. I should have led with that.

I have reached out to the ML Hub team with that information. Thank you for your detailed report :pray:

This is the current version i am on

Magic Leap HubVersion

The About doesn't show as much detail as my other machine.

Based on the logs we can see that gstreamer fails while trying to open device certificate for some reason. We get the certificate from the device (from rtsp-token command) and store it in a temp file. On MacOS, temp file will be buried somewhere inside the /var folder.

We had users report similar issues when when the file is missing / the path to that file does not exist. Can you verify that there is enough space on the MacOS device to store the var folder? Is there an antivirus that might not like temp files?

265GB free on the Mac and .8GB used on the ML. I will take a second and clear out some space and see if maybe that will help, but there should be plenty. :slight_smile:

update: rm'd 20gb and no change.

Thank you for that information. Additionally, try changing the Streaming type from from RTSPS to RTSP.

the device stream works when switching protocol :+1:

The advanced Capture says "respond to authorization" and then MLH immediately shuts itself down.

Do you mind capturing another bug report for the advanced capture issue?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.