MagicLeap MRTK3 1.0.0 import error

Hello all,

I'm trying to create a new Unity Project to use MRTK3. Yesterday it was working flawless, but today something seems wrong, could be connected to the recent news around MRTK3.
I am not able to import the MagicLeap MRTK3 package following the steps from the Magic Leap Developer Documentation:
Create a New Project | MagicLeap Developer Documentation.

I'm using the following configuration:
Unity Editor version: 2022.3.4f1
ML2 OS version: 1.3
MLSDK version: 1.3.0
MRTK version: MRTK3 - 1.0.0-pre.3

Error messages from logs (syntax-highlighting is supported via Markdown):

Error message copy paste:
[Package Manager Window] Error adding package: file:C:/Users/Anwender/MagicLeap/tools/unity/mrtk3/v1.0.0-pre.3/com.magicleap.mrtk3-1.0.0-pre.3.tgz.
Unable to add package [file:C:/Users/Anwender/MagicLeap/tools/unity/mrtk3/v1.0.0-pre.3/com.magicleap.mrtk3-1.0.0-pre.3.tgz]:
Package com.magicleap.mrtk3@file:C:\Users\Anwender\MagicLeap\tools\unity\mrtk3\v1.0.0-pre.3\com.magicleap.mrtk3-1.0.0-pre.3.tgz has invalid dependencies or related test packages: (dependency): Package [] cannot be found (dependency): Package [] cannot be found (dependency): Package [] cannot be found
UnityEditor.EditorApplication:Internal_CallUpdateFunctions ()

Looking forward to news around this topic, I would like to be able to use MRTK3 again :slight_smile:
Thanks in advance

@BatuOx4S make sure that you have the following packages imported in your project. You can verify the packages inside Unity's Package manager window.


I have the following packages installed:

Yet I still get the same error message.

There seems to be a problem with the 3.0.0-pre.18 - packages.

The pre.17 packages work fine.

1 Like

I had the same issue and going back to pre.17 wasn't an option for me. The fix for me was to open the tar file and change the "" references in the package.json that were giving me errors to their "" equivalents.