Keep Rebooting, Headpose tracking lost, and Crashing

ML2 OS version: both 1.3.0 dev2 and 1.4.0dev2

Here are the issues we've identified (and faced).

  • Weird noise from speaker when starting up.
  • The color on the screen sometimes appears to be separated.
  • The magic leap keeps rebooting.
  • Sometimes the magic leap was successfully booted, but after 1-2 minutes (sometimes even shorter), the display showed that "headpose tracking lost", and it crashed soon.
  • A thermal fault(led) occurred on the device, but we only powered it on without doing anything.

What we have tried.

  • Following the instruction given by the magic leap care, we have conducted both manual flashing and flashing with hubs. Also, we have updated to 1.4.0dev2; however, the problem keeps happening.

We have attached one log that we have successfully captured. (322.0 KB)

Any support will be appreciated.

I have tried to record the issue.
However, the video is too big, so I uploaded to Dropbox.
The video demonstrated how the crashing and rebooting happen.
However, I have difficulties recording the moment that the headpose tracking lost happened.
While I was trying the record these video, the headpose tracking lost issue also appeared sometimes; however, because it only happened when I wore the ML, and I have no chance to take off the ML and record it.