Issues setting up the device

I have multiple issues that I'm dealing with:

  1. After updating to B3E.220721.07-R.026_user, I can't see anything on the headset screens. The Compute Pack starts however, but without any video output. I tried downgrading to B3E.220619.07-R.124_user and that one looks fine. I tried upgrading and downgrading a few times, but with the same result - the "124" update works, while the "026" doesn't.
  2. I can't get the controller to update. It was working fine while the headset had the default firmware pre-installed. After the update from B3E.220321.01-R.068_userdebug to B3E_220424.01-R.037_userdebug, I am not able to update the controller. When I connect the controller to the Compute Pack, it actually recognizes the controller, and a pop-up saying "Controller updating, do not turn off the controller" appears. However, after a few seconds, a new pop-up "Controller update failed" appears. It disappears after 1 second, leaving only the former one visible. Unfortunately, the failed pop-up appears again in a few seconds, disappears after one sec, and this process repeats over and over again, making it impossible to finish updating the controller.
    I also tried flashing the controller from my PC (according to this link), but I can't get over the 4th step. Running erase_myriad.bat yields "No Instance(s) Available." output. So I tried to run those two commands, but after running the first one, I get "Device not found. Please enter FCMD COM number:", and I have no idea, what does the FCDM COM number mean. If I run both commands simultaneously, the CMD instantly closes.

Please help, this is really frustrating to deal with.

1 Like

Hi @jan.zigo,

Let's take some steps to troubleshoot this.

  1. Which method did you use to upgrade, The Lab's OS Installer or via command line? If you used the OS Installer, did you make sure that the "Reset Device to Factory Settings" box was checked?

  2. Have you tried to reset pairing on the controller following the step here and attempt to downgrade the Controller back to version R.124_user after you downgraded the compute pack?

1 Like
  1. I used The Lab's OS installer and I checked Factory Reset either when upgrading as well as downgrading the firmware.
  2. I tried both steps multiple times, but it always fails to install due to error that I described in the previous post.
1 Like

Jan, please try updating the device with the latest (newest) one that you can see in The Lab's Package Manager.

Our August release has a fix for the Controller flashing issues.

1 Like

Okay, so I tried once again updating from the oldest firmware to the latest sequentially (as described here). I could not connect and update controller in any of the older updates. As soon as I upgraded from R.124 to R.026, the first issue (no visual output in the goggles) happened again. Nevertheless I tried connecting controller to the Compute Pack. This time, it looked like it's doing something, but since I couldn't see any info on the installation process, I disconnected after about 5 minutes. Since then, the controller changed its behaviour - it was flashing red light and beeping. So I tried downgrading the OS from R.026 to R.124. Finally, after that step, I was able to update and connect the controller.
Therefore, the second issue seems to be resolved. However, the first issue (no visual output for the R.026 update) is still present. I tried once again uprading from R.124 to R.026, but unsuccessfully. So I'm sticking to the R.124 update for now.

1 Like

With a new software release, it's time to revisit the issue to see if it can help resolve this problem:

1 Like

I'm experiencing a similar issue, on both the no visual output and controller update front.

I also had the no visual output issue when I tried to upgrade, so I rolled back to the first version of firmware and then updated incrementally. When I rolled back, I immediately had visuals again.

I got to R.085 and tried to update the controller, but the device appeared to reboot itself mid update and the controller LED turned off, so it appeared the controller firmware stopped updating. I figured this might be because I wasn't on the latest firmware, so I tried to update.

However, on the latest version (B3E.220818.12-R.046-R.417_user) I experience the no output issue again. And now my controller also has a red LED. So I rolled back to the previous version where I had display (R.085_user) and will see if I can successfully update the controller again.

I get a notification that the controller is updating and this may take 5 minutes, and then the device reboots. It has power cycled three times now, and not shown any indicator of the controller update completing. Is this expected, or is there another way to track the controller update progress?

When I did forward updates, I didn't update the controller firmware each time. Do I also need to incrementally update the controller firmware (and should I go back to the original version and incrementally update both the device and controller again?)?

Thanks for your help on this!

1 Like

And just to follow up: Even after 10 minutes, my device was still power cycling, so I unplugged the controller. The red LED came back on and it made a noise. My device is still power cycling.

I see a notification that Headset tracking is lost (which doesn't go away even when I follow the instructions to Try moving and looking around your space) overlayed with what looks like the quick start guide. Then the device power cycles again.

I'll likely try rolling back to other versions.

1 Like

I kept rolling back and trying to update - I ended up on 220619.07-R.124 and then didn't have the issue where headset tracking was lost, and was able to update my controller without it power cycling. Will try doing this, but for each incremental update now.

1 Like

I would recommend updating to the latest OS update as of October now. You must do a factory reset when you flash new OSes. This will not be true after this October release, but until now, it is necessary.

1 Like

Hey Shane, I have flashed the newest OS incrementally and left the "factory reset" option selected each time. On the latest OS, I am getting no display and my controller LED is red (meaning the firmware is out of date). I do hear noises coming. from the headset occasionally.

What are my options here? I can roll back to an older OS and get display, but I want to be developing for the newest OS with the most recent SDK.

1 Like (4 KB)

Here's the bug report generated from Magic Leap Hub, if that's helpful.

We'll get you up and running. Let me assign someone to get back to you.

1 Like

@kvlasova , can you guide @john through this?

1 Like

Hi John,

Reading through the thread I noticed that you were asking about whether the controller update with each version increment is necessary - yes, it is, and it's possible that that this is what has caused your controller issues. It is also imperative that the "Reset device to factory settings" field is left checked with every new OS update, we have had loss of display reported to us when this was not done.

Can you confirm the following for me?:

  • What OS version did you last try to flash the headset and controller to?
  • Is your device currently able to be detected by ML Hub?
  • If it is not detected by ML Hub, is it detected by running "adb devices" in command line (with the headset connected to the computer and powered on)?
  • If it is not detected by either above, is it detected by running "fastboot devices" in command line?

I can also get on a call with you today until 5pm EST or some time next week to troubleshoot this live.

1 Like

Hey Kat, thank you for the quick response!

My ML Hub automatically selects "Reset device to Factory settings" and to my knowledge I haven't touched it, despite multiple attempts at getting to the newest firmware.

  • I last tried to get to 220818.12-R.046-417_user
  • Yes, it is

I tried flashing all the way back to 220619.07-R.107, where I now have visuals. But when I plugged in the controller, it updated and connects, but there is no pointer on the screen or response to input. I'm looking at a screen that says "Your controller is updated and ready to use". I've tried restarting and reconnecting, but no luck. Are there any ways for me to debug the controller issue before I try flashing forward again?

If you don't have any immediate suggestions, I'm free Wednesday from 11PT onwards if you are available to trouble shoot this live.

1 Like

Hi @john,

I'm going to send you a video call invite for Wednesday at 11:00am PST so we can troubleshoot this :slight_smile:

Hi @john,

As mentioned in our call, here is the Controller Recovery Guide that you need to follow on your Windows machine. Let me know if you run into any issues.

1 Like

Hi @kvlasova , unfortunately after following the controller recovery guide the result is the same. The controller connects to the device, but there is no pointer and no response to any of the buttons.

I tried following the steps at the bottom of the controller reset guide (repairing the controller). I cannot try rolling back the compute pack to a previous firmware version, because there isn't one available.

Where can I go from here? Is it possible something is wrong with the device and not the controller? Do I have any other troubleshooting options?

Thanks for your help!

1 Like

I'm facing the same issue and wonder which OS versions is the control_4992-R2 compatible with? OS version and controller version seem to be paired:

I'm currently running B3E.220619.07-R.124 on the compute pack because it's the last version I had almost working.

1 Like