How to Enable Magic leap Feautre?

Unity Editor version (if applicable): 2022.3.13
ML2 OS version: 1.5.0
MLSDK version: 1.5.0

Magic Leap HubVersion 2.0.17.202312111547
Magic Leap Application Simulator Module Version 3.8.0.202312080701
Magic Leap Application Simulator Runtime Version 3.8.0.20231208
Server: 3.8 (built Dec 8 2023), Protocol: 27
ZIF (bundled): Version 0.0.35.20231208
ZIF (runtime): Version 0.0.35.20231208
Windows

After recently updating my OS etc, I am not getting Magic Leap API permissions from Unity. Features such as Plane Detection are disabled. What should I do?



Hi @primepaejh,

Thank you for reaching out to us and providing screenshots. I have consulted our team regarding this issue and I will report back as soon as I learn more.

Best,

El

Does it work after closing and reopening the Unity Editor?

No matter how many times I turn it off and on, it doesn't work, even when I turn my computer off and on.

Can you verify that the project is targeting Android in the build settings and that you are looking at the Android tab in the project validation window?

In the image you posted it looks like the Spatial Mapping permission and the Plane Detection features are enabled, are you having issues running the application on device? Have you requested the permission explicitly? Requesting Permissions | MagicLeap Developer Documentation

Yeah, we're all set. I'll attach the Unity logs as well.


I’m not sure I understand. Were you able to get the Magic Leap Unity Example project to work? Have you noticed differences in the package versions between the examples and your project?

Do you have Open XR and Magic Leap selected as the target platforms in Unity’s Xr manager?

I haven't tried the example, but my application was working fine until I updated the Magic Leap Application Simulator to Version 3.8.0 in the Maigc Leap HUB. I tried selecting both OpenXR and Magic Leap in the XR Manager, and I tried selecting only Magic Leap, but neither worked. I tried uninstalling and reinstalling Unity Editor, but it's still the same. What can I do?



I keep getting this LOG in Untiy. Does anyone know anything? I'll attach all the things I have set up now.

Thank you for the additional information.

The OpenXR APIs are not supported in App Simulator at this time. Do you mind deselecting the XR Package Manager settings and disabling the OpenXR option in both the standalone and Android tabs?

Once deselected, please import the com.unity.xr.magicleap version 7.0.0 package via the package manager. (Select the plus icon and select "by name" . This will ensure that the correct package version is installed.

Once installed, re-enable Magic Leap (Not OpenXR) in the XR Plug-in Management window under both the Standalone and Android tabs.

tried, but still no luck. I've even created a new Unity project and run the examples provided by Magic Leap Hub, and I'm having the same problem. I've looked up and tried so many things, but I'm not getting anywhere. What can I do?



I started a completely clean setup on a different desktop than the laptop I was using, installed Unity, and did a clean install of Magic Leap Hub again, but when I run the same Plane example, I get the same error log and no Pland Detection. I've tried everything you suggested and it's the same.

Are you using the 1.12.0 version of the Magic Leap examples project? The 2.0.0 Unity Examples are configured exclusively for OpenXR and will not work inside the simulator.

I changed to version 1.12.0 and ran the example again, but this time I got a different error log. How can I fix this error?


By the way, I used Magic leap SDK version 2.0.0 even before I updated Magic leap Simulator from 3.7 to 3.8 and Magic leap os to 1.5.0. I had no problems then. All the problems started after the update. Can't you at least enable rollback?

Can you verify that OpenXR is disabled in the Standalone tab in the XR Plugin Management ? I also recommend removing the OpenXR package when using the 1.12.0 Unity SDK version as it is not guaranteed to support the OpenXR package that you are using.

Plane Detection is finally enabled! Thank you! But the RayCast feature still doesn't work. How can I fix this?


The Magic Leap SDK does not support the XR Raycast Subsystem at this time. As an alternative, use the Unity Physics Raycast instead and the Physics Culling Layers to filter which colliders are raycasted agaisnt.

Everything is fixed, thank you so much for your help!!!

1 Like