Zi bundle and runtime versions do not match

Give us as much detail as possible regarding the issue you're experiencing.

Unity Editor version: 2022.2.11f1
ML2 OS version:
MLSDK version: 1.3.0-dev1
Host OS: Windows 10

Error messages from logs (syntax-highlighting is supported via Markdown):
logfile.txt (683.3 KB)

The issue I'm running into happens when I try and run with a target simulation ( I don't have a connected device). I get an error that the appsim package differs from the runtime. I'm not sure why though, all of my packages are up to date in the ML Hub and everything else seems to be fine from what I can tell. Though I am a complete beginner. I also don't see the bundle version in the ML Hub though I can find the runtime version. Here is the error:

Here is the view of the ML Hub packages

And this is what the Setup Tool in Unity looks like

I'm not quite sure how to resolve this so that I can test in the Unity App Simulator. I am going to try starting a brand new project and going through the setup steps again, but any advice would be appreciated.

1 Like

Hi @dreams can you check that the App Sim Runtime package linked inside Unity is correct? You will see it listed under Unity > Preferences > External Tools > Magic Leap under App Simulator Runtime Override

That version number needs to match the Magic Leap App Simulator package version you have installed in ML Hub and the App Sim for Unity package version if you are using that within your project.

This is what it shows, which matches my installed runtime app simulator.

I can't seem to locate the ZIF Version (bundled) version. I assume this is a version that came out on May 4th but I can't find it in the ML Hub. Also all of 'My Tools' in the ML Hub are up to date so I'm not sure where that version is.

Not really an update but this is the error

Packages are all still up to date. Any way I can find what the currently running ZI Server is?

@dreams Did you have an existing installation of the Application Simulator prior to the most recent release, where you used it on your device?

I did not. This is my first time doing anything with Magic Leap or ML2.

I have the same issue. It looks like the com.magicleap.appsim.tgz
is a different version than what is in the tools/zi/v3.5.0.20230410.

I am having very similar issues, getting the same errors with the ZIF version differing and the ZI server failing to start. I noticed when checking the App Sim Diagnostic Tool, though, that the system seems to expect App Sim Runtime Version; I have tried to find this version, but I have not found a single trace of it on the Internet or in the ML Hub. As a new ML developer, I'd really appreciate if anybody could help!


Same issue here.
Is there any workaround?

Same error here.

Running: 3.5.0
Expected: 3.6.0

Thank you for raising this, all. We're diving into this now and hope to have a solution asap.

Fyi all: Thank you for reporting this. This resulted from a discrepancy when we published our last update. We have a fix for this discrepancy currently scheduled for Wednesday, June 14. Thank you all for raising this issue.

1 Like

Is there another option to test the apps on the simulator when i'm using Unity?
I've tried Application Simulator from Magic Leap Hub. But i can't click anything.
Also when i've tried run Anchor scene from MagicLeap_Examples im getting errors

Error: MLZIPermissionsIsGranted in the Magic Leap API failed. Reason: MLResult_PermissionDenied

Error: StartAPI in the Magic Leap API failed. Reason: MLResult_PermissionDenied 

Error: MLAnchors requires missing permission com.magicleap.permission.SPATIAL_ANCHOR

I've checked the latest update and now i can simulate on Unity Editor but still i have issue with MLResult. I can't interact with any UI elements
Any idea?

Hello! I'm still having issues myself but got rid of the MLResult error. It had something to do with this screen for me.

I believe the error shows if you are just using the simulator and may be trying to activate permissions that would require a headset? But I would double check the permissions that you need and only activate those.
It looks like from your error that you need to activate / allow the Spatial Anchor field that I highlighted.

I regret to say that same problem happens with different versions:

[ZIF] The ZIF version in the 'com.magicleap.appsim' package (0.0.33) differs from the one in the App Sim runtime (0.0.34).
This will lead to problems.
UnityEngine.Debug:LogErrorFormat (string,object)
MagicLeap.ZI.EnvironmentPathProvider:CheckVersionInfo () (at ./Library/PackageCache/com.magicleap.appsim@b7f763bd5abe/ZIFUnity/ZIBridge/ServiceProviders/EnvironmentPathProvider.cs:103)
MagicLeap.ZI.EnvironmentPathProvider:Update (string,bool) (at ./Library/PackageCache/com.magicleap.appsim@b7f763bd5abe/ZIFUnity/ZIBridge/ServiceProviders/EnvironmentPathProvider.cs:74)
MagicLeap.ZI.MagicLeapSdkPathProvider:Update (string,bool) (at ./Library/PackageCache/com.magicleap.appsim@b7f763bd5abe/ZIFUnity/ZIBridge/ServiceProviders/MagicLeapSdkPathProvider.cs:95)
MagicLeap.ZI.ZIBridge:UpdateSDKPaths (bool) (at ./Library/PackageCache/com.magicleap.appsim@b7f763bd5abe/ZIFUnity/ZIBridge/ZIBridgeEnvironmentManagement.cs:58)
MagicLeap.ZI.ZIBridge:OnEditorApplicationUpdate () (at ./Library/PackageCache/com.magicleap.appsim@b7f763bd5abe/ZIFUnity/ZIBridge/ZIBridge.cs:124)
UnityEditor.EditorApplication:Internal_CallUpdateFunctions ()

I had this same issue when I updated my packages and project.
[ZIF] The ZIF version in the 'com.magicleap.appsim' package (0.0.33) differs from the one in the App Sim runtime (0.0.34).

@dreams and @bastiao, Where did you import the com.magicleap.appsim package to Unity? It’s supposed to be from a folder like $HOME//MagicLeap/tools/app_sim_unity/v3.6.0.20230609 .

If that folder does not exist, check in Package Manager and make sure the proper version is installed.

No. If I put the path you mention it says says:

So I used that, but I've the error.

Hello Bastiao! I believe I have mine working and I think I may have an idea what the issue was.

I'm going to have a bit of pictures b/c they explain it better than I do! So I set up using the magic leap setup tool, fixed the URP stuff, and fixed things where need be. The issue came in when trying to get the app sim to work.
I ended up having to import it in the package manager using the tarball

This tarball was located here (that worked)

Which is different from where my app sim runtime is found (same as yours)

Not sure if that will help at all but after I installed the package via tarball from the other folder it seems to have linked up.

Oh, I also have the Magic Leap Hub app simulator open.

One more edit / picture of the versions lining up:

And maybe @kdowney would know better if this makes sense why it worked.