Getting started tutorial problem Mac OS Unity Magic Leap 2

Hey, I am going through the getting started tutorial with Unity 2022.3.0f1 on Mac (13.5.1) with mlsdk 1.3.0. I am able to deploy and run the app on my Magic Leap 2 (OS 1.2.0). But nothing is rendered (not even Made with Unity logo). I get the following lines in the log:

Unity;[XR] [XR::Display] begin_frame() retured: InvalidParam;

Any suggestions on how to address this? Thank you.

Hi @sjcomp,

Thank you for reaching out regarding this issue with the getting started tutorial. I will go ahead and attempt to reproduce this issue. Would you mind providing reproduction steps?



I was following the steps from official ML docs. I have created a project, and used Magic Leap Setup Tool from the Unity Asset Store. I configured rendering pipeline and created a simple app. Everything looks fine in the simulator. I am not allowed to post links yet: developer-docs /guides/unity/getting-started/unity-building-simple-app

My coworker followed these steps on their windows machine and they were successful deploying to my Magic Leap 2 device. When I used their project on my mac, I got the failure above. I followed the tutorial myself from scratch and still I have the same error on a new project from scratch. My mac is M1, in case that's relevant.

Does the same issue occur when building other projects?

Hi @sjcomp
could you try building the sdk examples project and see if you have the same problem?
M1 mac should be fine :v: M2 has trouble right now iirc.
Thank you,

Yes. I had this problem with all projects I tried to build.

Thank you for the suggestion. I tried building sample projects, with the same result. Hence I tried making the simple app, as a way to see if there is something I am missing in the setup.

I've asked the question at unity forums and EmadG_dolf there had a similar issue. He recommended upgrading OS to 1.31, as it fixed the problem for him. I did the same and it also fixed the issue for me. Thank you.

1 Like