Fail to interact with button

I met a bug when working with Application Simulator and I am writing to discuss that if there are some tips about solving it.

When I click the play button in unity, the scene was correctly displayed in the Application Simulator. The data in UI, for example, controller scene, was changing correctly when I move/rotate/click buttons on controller. However, when I moved the indicator on the button and tried to click it, although the UI showed trigger is clicked, nothing happened there. (As showed in attached image) I test it several times and the button events (both hover and click) weren't triggered.

To solve this problem, I looked into the code of the UI and they are all correct. In addition, I test the project on MagicLeap 2 device and the buttons worked properly (I think this can indicate that the error is not caused by the code). Then, I tried to reconfig both of Unity and Application Simulator, and I tried with various versions of MLSDK and Application Simulators. But none of them worked. Finally, I search on google and unity forum but there's no related topic about it.

For information of my system, I am on WIndows 10, using unity 2022.2.0.f1, MLC SDK is 1.5.0 and Magic Leap Application Simulator (ZI) Runtime version is

Hi @yanghouze,

Welcome to the Magic Leap 2 Developer Forums. We are so grateful to have you here engaging with us.

Is this solution helpful for you? I will be sure to let our team know about this issue to have it be more visually apparent.



Thank you very much, that helps a lot and solve my problem. The problem is that I am using the end of red ray to click but actually I should somewhere in middle. After solved the problem following your instruction, I also tried to uncheck rendering two eyes and keep the manipulation model as None. The scene still works. May I ask that what is the purpose for these setting please?

In the App Simulator, the two-eye rendering setting changes the device view to display both eyes rather than a single eye view.

The manipulation mode selection of "none" allows you to select the object without translating, rotating, or scaling the object. This is helpful for selecting the object without accidentally manipulating it.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.