Enabling Speech Input Causes Error Logs In Editor

I'm getting the same error (MLResult_UnspecifiedFailure) every update frame when in editor. To the best of my knowledge this isn't causing any issues when I build onto the device. The errors show up whenever I enable the speech input under the MRTK script.

I enabled debug to try and figure out what was causing the error logs and found the source line.

From what I can see its a unity editor call only, which explains why the build is still fine. I was initially gonna edit the code to ignore the permission, but the script is from an external source and I cant edit it.

And yes, I do have the permissions enabled.


Unity Editor version: 2022.2.17
ML2 OS version: 1.2.0
MLSDK version: 1.6.0
Host OS: Windows

Here is the actual error msg call stack:


  • Do these errors persist after clearing from the Console?
  • Are you able to build/compile to a headset?
  • Yes, I've cleared the console. The errors happen every time I run the app in editor.

  • Yes, I can build for the device without issues. At this point its just more of a nuisance and its affecting performance in editor because of the error log spam.

Do you have this asset integrated in your project?

If not, can you see if it can resolve this. It is saying something about "ZI" (also known as the App Sim) and this asset can assist with making sure that's enabled correctly.

@nathan and this issue is still happening? Are you using the MRTK simulator? I would not necessarily expect your scene to "just work" when you click "play" in Unity.

I would recommend getting the App Sim for Unity set up: MagicLeap Developer Documentation

Just glanced through it, I actually dont want to use the ZI app sim. I believe I've been using the MRTK input simulator in editor like you said.

Is there a way to disable the app sim? I dont have the app sim package installed since it caused issues a while back.

@nathan Can you try the following:

De-select "Magic Leap App Simulator" from the XR Plug-in Management options for "Standalone" (as show in the screenshot). The errors may persist, unfortunately, but you will be able to Play as expected.

Thanks, errors are gone. Much appreciated!