App Simulator Unresponsive and Takes Down Complete Hub

Directly after starting the ML App Simulator, it becomes unresponsive and displays "Restoring Application Simulator Session..." in the Device View tab; in addition, it takes down the complete ML Hub.

I am on an Apple M1 running macOS Sonoma Version 14.0. The App Simulator worked a couple of days ago on this machine, and it also worked in combination with Unity 2022.2.0f1 (usability and performance of the App Simulator are a different rather sad story :face_with_spiral_eyes:).

After getting the above mentioned "Restoring Application Simulator Session..." unresponsiveness and not being able to solve it, I removed the entire ML Hub and all files in my home under "~/MagicLeap". I reinstalled the ML Hub but I do get the very same result. In the process, I killed the ML Hub several times; there may be some stuff still lying around somewhere. The log file shows "2023-10-15 12:16:54.145 ERROR SceneViewTextureViewerPart: Failed to read Simulator configuration", which seems to somewhat support this assumption.

Maybe the solution is as simple as deleting some inconsistent state somewhere?

ML, I really do like your device - a lot! I hope you will improve your software stack and usability in the month to come. One improvement should be an easy way to do a clean and complete uninstall of the ML Hub to then start afresh.

Thank you!

Hi @xrc, can you post your "Save Diagnostic Logs" here? We have made some improvements to Application Simulator stability that will hopefully improve your workflow.
Also are you using the Simulator in Unity or in the Hub itself?