Deploying AR Cloud on Vmware Vsphere

Hi folks

I have downloaded the OVA from the dev portal and tried to spin up a VM using the OVA as a template on Vsphere.

I get the following error:

Issues detected with selected template. Details: - -1:-1:VALUE_ILLEGAL: No supported hardware versions among [virtualbox-2.2]; supported: [vmx-04, vmx-07, vmx-08, vmx-09, vmx-10, vmx-11, vmx-12, vmx-13, vmx-14, vmx-15, vmx-16, vmx-17, vmx-18, vmx-19].

Which makes sense.. the OVA is for Virtual Box. So I modified the OVA by changing <vssd:VirtualSystemType>virtualbox-2.2</vssd:VirtualSystemType> to <vssd:VirtualSystemType>vmx-19</vssd:VirtualSystemType>, and then rebuilt the OVA (yes, using a valid sha256 hash).

I then tried to reimport but get a different error about unsupported ResourceSubType.

Has anyone been able to successfully deploy AR Cloud into Vmware for testing?

Hi @abdullah,

Welcome to the Magic Leap 2 Developer Forums. We are so grateful to have you here engaging with us.

I have reached out to our team regarding your issue and I will report back as soon as I get an update.



Thanks El,

If there isn't an easy solution to this, I can always try the 'custom deployment' method.

Hi @abdullah,

The error seems to be saying that OVA specifies the system type as virtualbox-2-2. We recommend changing the file metadata or using VirtualBox.

Let me know if this helps.



Hi @etucker,

We've already done this, I mentioned this in the initial post however this did not work.

Apologies for my misunderstanding. So the primary blocker is the ResourceSubType issue? Just to be sure.

Yes that seems to be the error we're getting now.

We do have a support ticket open (#30769) so I'll mention this thread on there.

1 Like

Hi @abdullah,

You should be good to take it from here in your support ticket. If you have additional concerns please let me know!