Can't change splashscreen

Give us as much detail as possible regarding the issue you're experiencing.

Unity Editor version:
ML2 OS version:
MLSDK version:
I've tried a bunch of different settings to get the splash screen to work, but it will always just show the unity logo.

These settings give no splash screen at all:

These settings just shows the unity logo;

Changing the background color does however seem to have an effect, but it's still just the unity splash screen on top;

Thought the issue was the source being a sprite, so changed it to default (texture 2D) and now getting this crash on startup;

With these settings;

Alrighty, seems to have been because the texture resolution was non-power-of-two.
So that fixed it with these settings;

1 Like

Thank you for your post and the update @TheMunk.

Alrighty, the bug crash came back - even with PoT textures (and without alpha, just for testing).
Some builds gives the native error in logcat, while others doesn't even print to logcat.

I've added the tombstone;
tombstone_01.txt (321.4 KB)

Just saw this on cloud diagnostics - might be more useful

Native StackTrace:

Thread 0 (crashed)
0                        0x0000712ad0512ea2 XRSplashScreen::CreateSplashObjects(float) 
1                        0x0000712ad0512d49 XRSplashScreen::Update() 
2                        0x0000712ad050d52a VRDeviceToXRDisplay::UpdateVRSplashScreen(XRDisplaySubsystem*) 
3                        0x0000712ad052ea8b VRModule::EarlyUpdate() 
4                        0x0000712acff4ddf0 CallbackArray::Invoke() 
5                        0x0000712acffb715a ExecutePlayerLoop (/home/bokken/build/output/unity/unity/Runtime/Misc/PlayerLoop.cpp:386)
6                        0x0000712acffb719e ExecutePlayerLoop (/home/bokken/build/output/unity/unity/Runtime/Misc/PlayerLoop.cpp:407)
7                        0x0000712acffb7409 PlayerLoop (/home/bokken/build/output/unity/unity/Runtime/Misc/PlayerLoop.cpp:514)
8                        0x0000712ad0142db1 UnityPlayerLoop (/home/bokken/build/output/unity/unity/PlatformDependent/AndroidPlayer/Source/EntryPoint.cpp:1208)
9                        0x0000712ad015c3ce nativeRender (/home/bokken/build/output/unity/unity/PlatformDependent/AndroidPlayer/Source/JNI_OnLoad.cpp:164)
10  base.odex                          0x0000712ad1acae0d <symbols missing for uuid: 0000000000000000000000000000000000000000> 

This crash still happens consistently with latest 1.6.0 SDK.
Any news?
We currently cant use a splash screen.

I just tried building a sample app with a custom "Virtual Reality Splash Image" texture (with non-power of two resolution, w/ and wo/ alpha) as well as with the splash screen disabled and it ran fine on an ML2 in all cases. Thanks for posting the call stack. It sounds like there may have been a bug in the Unity player. I tried building with Unity 2022.2.15f1, which is a bit newer.

Are you able to try updating Unity to the latest version of 2022.2?

I did notice that tweaking settings in the "Logos" section of the player settings did not appear to have any effect when running on the ML2. You'll always just see either the Unity logo or the "Virtual Reality Splash Image" texture if one has selected. That may just be a limitation of how Unity has implemented the splash screen for XR apps.

@TheMunk Any updates? Did @aheaney 's response resolve it?

We have yet to take the unity update step - will let you know once we have tried this.