App Sim Target (in Unity) not working

Unity Editor version: 2022.3.18f1
ML2 OS version:1.5.0
Unity SDK version:1.12.1 / 2.0
Host OS: (Windows/MacOS) Windows 11
App Sim Unity package: 3.8.0-20231208 (tried multiple packages, getting same error)

Error messages from logs (syntax-highlighting is supported via Markdown):
[ZIF] The ZIF version in the 'com.magicleap.appsim' package (0.0.35) differs from the one in the App Sim runtime (0.0.34).
This will lead to problems.
On hitting play on the App Sim Target, get following error message On Unity console:
Failed to start the ZI server: the App Sim frontend is not compatible with the currently running App Sim server

Hi @aps,

Are you using the App Simulator for Unity package? Are you using the ML Hub?

From our App Sim release notes:

The 2.0.0 version of the Magic Leap Unity SDK and Unity Example packages available from the Package Manager target OpenXR and do not currently support Application Simulator. Developers are advised to continue using Unity SDK 1.12.1 or older until an OpenXR-compatible update for the Application Simulator is released.

This may be the cause of your issue. Let us know if you have any further questions.

Best,

El

I am using the Unity app sim package. I am using SDK 1.12.1

Here is a screen shot of the Preferences window:

Do you mind capturing the logs from after the App Simulator fails to connect. There should be an option to collect them under the Magic Leap menu item on the top of the Unity Editor.

Attaching it here:
MLHubLogs-20240328143736.zip (54.0 KB)

Can you please try using the 3.8.0-20231208 version of the zi runtime?

MagicLeap/tools/zi/3.8.0-20231208/

Changing the run time got it working. Thanks. I am seeing a bunch of errors on hitting Play. But it may be related to our application.