Saving local files on device

Hi, I am trying to save a local file on the device (ML2) and the file is not showing up (and there are no errors, as far as I can see)

I tried to follow with that Saving and Loading - filedir? - Unity Development - Magic Leap 2 Developer Forums solution with no results.

I wonder, has something changed since a year ago?

Unfortunately we will need more information to help you. Can you provide information or steps to reproduce the issue? We use the same file management APIs as a standard Android 10 device which allows you to use a lot of the resources online to save and locate files. If you believe that our device is behaving differently, you can test your application using Android Studio's Emulator to verify the expected behavior.

To use the Android Studio Emulator, create a virtual x86_64 Android 10 device without google play services. Then create a sample application with the file system logic and build it as a standard Android app targeting x86_64. Once built, you can install the application on the Emulator to verify it's functionality. If the app was compiled for x86_64 you will also be able to install it on Magic Leap 2 as a standard 2D application and compare the result.

I tried the simplest function to write a file, and while it was working fine with Quest 3 (file was created), the same function did not produce a file on ML2.

    public static void WriteString()
        string path = Application.persistentDataPath + "/test.txt";
        //Write some text to the test.txt file
        StreamWriter writer = new StreamWriter(path, true);

That function should work on Magic Leap 2 as well. Do you get an error when trying to save the file? Can you verify that your app has the permission? Did it prompt your for write permission when you first opened the application?