Passthrough Issue with Black Background in Recorded Videos during Remote Rendering on Magic Leap 2

-unreal engine5.3
-window 11 pro

I am facing a specific issue with the Magic Leap 2 when performing remote rendering using Unreal Engine. The passthrough works fine during live remote rendering sessions, but when I record these sessions, the video playback shows a solid black background instead of the transparent environment.

Today, suddenly the passthrough works but ar content appears transparently like second pic.

Any advice on how to fix this so that the recorded videos reflect the actual passthrough environment would be very helpful.

Thank you for your assistance!

A few notes and possibilities,

  1. Have you tried using the debug gui panel to see what might be overriding the alpha channel :Troubleshooting Remote Render | MagicLeap Developer Documentation
    2.We use alpha both to control the capture opacity, and the segmented dimmer. So bad alpha impacts both scenarios. I recommend taking a look at the following guide: Remote Rendering with Unreal Engine 5 | MagicLeap Developer Documentation.
  2. Unreal by default enables ALPHA_BLEND, but if the application does not submit alpha properly then that is all initialized to 1.0. This should also coincide with the segmented dimmer being at max strength everywhere (Although this would cause the dimmer to be enabled in the headset at runtime)