Microsoft Express SQL Connection

Give us as much detail as possible regarding the issue you're experiencing.

Unity Editor version: 2022.2.3f1
ML2 OS version: 1.1.0
MLSDK version: 1.3.0
Host OS: Windows


we have a question regarding a sql connection from the magic leap device to a microsoft sql server.
It is working in Unity Play-Mode and also on Android-Phones but sadly not on our ML2 device.

We use the System.Data.SqlClient and we would like to know if ML2 supports this library?

If not, are there any recommendations for different sql clients?

Thank you in advance!

Hopefully there is an answer.

Here is a SS from our main Problem:

1 Like

We have an update on our Problem:

We found out that our sql library is not the main issue but the ML2 encoding method.

As the error message shows the codeset assembly isn't installed or enabled on the device.
Can it be the case, that ML2 does not support utf-8 and uses 1252 Windows encoding?

We are asking ourselves why ML2 uses 1252 and not the international standard (e.g. utf-8-encoding).
Is it possible to install and enable the codeset assembly or are we taking the wrong approach here?

Thank you for reading!

1 Like

Hi @a.reality, thank you for your post. I talked to our engineers about this, and It should work since System.Data.SqlClient is part of Unity's System.Data library. There shouldn’t be anything special ML2-wise here — it should just work like any other Unity Android app in this regard. One caveat is if there is native code in a lib that is compiled for only arm64 and not also amd64.

Without logs or specific error message you receive, it's difficult to say what this issue is but here are some resources you may find helpful.

Also, Magic Leap 2 supports utf-8 encoding to answer your other question. Thank you and best of luck.

1 Like

Apologies, I missed your attached screenshot with the error you're receiving. Let me take this back to our team and discuss. Please let me know if you have any additional error logs or information. Thank you again.


Thank you for the reply,

we sadly do not have any further error msg / logs about the problem, this is the only error that shows up whenever we try to access the SQL server.

We have tried different options and ways but the problem still remains (assembly references, different connection strings, different encodings in the script etc.)

On all of our Android phones up until now the SQL connection has worked flawlessly, that is why we are thinking it could have something to do with the ML2 Device.

Thank you again, hopefully we can find an answer !

1 Like

Thank you @a.reality. I revisted this with our engineering team and overall it seems your database or connection somehow is using an old encoding format known as “West/1252,” as you referenced above. However that is not mandated by Magic Leap 2.

Have you tried this yet? It seems there may be a few different solutions around from what I have seen. Here are some resources that may be helpful. Please let us know how it goes.