Flicker issue during remote rendering

Give us as much detail as possible regarding the issue you're experiencing:

Magic Leap SDK version: 1.6.0
Unreal Engine version: 5.3
ML2 OS version: 1.6.0

Error messages from logs (syntax-highlighting is supported via Markdown):

Hi,

I have flickering issue with remote rendering.

I've read this topic as below.

From my understanding, the flicker issue has been solved with the upcoming OS.

I wonder if OS 1.6.0 includes this issue solved?

Hello,

Our remote render team works to make improvements to our remote rendering service and viewer application with each platform release. ML OS 1.6 is the latest version of the OS that has been released. I would recommend using the latest version of the ML remote rendering service and viewer app (v1.11.64) with OS 1.6.

It is possible that you may have a better experience with the current version of ML remote rendering if you experienced issues in the past with a prior version.

That said, we will be releasing new version of ML remote rendering very soon along with the next ML OS release (1.7) which has some changes that are specifically meant to make the runtime more robust to situations that might lead to performance degradation. I would recommend that you try using the new release once it's available. I'll reply to this thread once the new version has been released.

Best,
Adam

Thank you for your help

Additionally, If there is a problem after the update, is it possible to go back to the previous version?

Yes, you can download older releases of remote rendering and ML OS using the package manager in ML Hub. I'd recommend manually uninstalling MagicLeap remote rendering in Windows prior to installing an older version. (start -> add or remove programs -> magicleap remote rendering)

Also, note that if you flash a version of ML OS that is older than the one that you currently have installed on your ML2, then device will be factory reset. You will lose any data that you had stored on the device and you will need to reinstall any applications. I'd recommend backing up any data on you ML2 prior to installing an older OS.

Best,
Adam

Hello,

Just to let you know, ML OS 1.7 and ML remote rendering 1.12.87 have been released on ML Hub if you'd like to give them a try.

Note, when you update to ML OS 1.7, you will need to manually enable developer mode and usb debugging before you will be able to update the remote render viewer application.
This forum post has details on how to enable usb debugging- USB Debugging Disabled By Default (OS v1.7.0)

Best,
Adam