Blank Unity app after updating to 7.0.0-exp.4

Hey Everybody,

I have a working app that completely fails when I updated the ML XR package to 7.0.0-exp4. With 7.0.0-exp3 it works as expected, then after the update the app gives me nothing but a black screen: no splash screen, no nothing. I'm using the headlock app mode, could be some strange interaction with that setting.

Has anybody else seen this?

Usually I see something labeled "Experimental" and I'm like "yes, please" .... but maybe now I'll think twice about this. :thinking:

Unity Editor version: 2022.2.0b8
ML2 OS version: Build: B3E.220721.07-R.027
SDK Version 29
MLSDK version: 0.53.3

You need to update your ML2 OS to B3E.220818.12-R.085 .

1 Like

Thank you, Shane! I must have missed that.

1 Like

We just updated to 085, and followed the online setup + MRTK instructions from a fresh project. Using Unity 2022.2.0b8, and still get a blank screen. We have removed all the quality settings except 1 as well.

1 Like

Same here with 7.0.0-exp.4 - black screen with critical errors in the log.
Also upgrading to Unity SDK 0.53.3 / MRTK 0.53.3- v1 seems to break headpose tracking. Content just follows the camera.

1 Like

@ebelkin , "seems to break headpose tracking."

I'll declare that it's impossible for that to be the case. Are you experiencing a shaky camera? I need as much information as you can provide.

1 Like

@sengelman I'll try to dig deeper and if I can confirm, I'll create a new thread in order not to mess with the current subject.

1 Like

I'm seeing similar behavior here -

We updated our project to SDK v0.53.3.

We updated one of our headsets to R.085 - the other is still on R.027.

Nothing works on the R.085 - even with the Magic Leap XR Plugin-7.0.0-exp.4 - we get no splash screen at all, and nothing of interest in the log;

We can build fine to the R.027 with exp.3 and the same SDK setup.

Will try to roll back to R.027 until this has been fixed.

Rollback fixed everything.
P.S. our devices are the "non-secure" internal ones - not the public.


Is your application using plane finding ? Can you make sure that graphics jobs are disabled in your player settings?

If graphics jobs is disabled, please try closing your Unity application and deleting the XR folder in your assets. Then re-opening the project. After reopening the project you may need to enable the Magic Leap XR provider in the xr manager again.

After that is complete verify that the com.unity.xr.magicleap-exp3 package is imported.


Sorry for the late reply - disabling graphics jobs seems to have solved the issue.
Any plans on bringing that feature back?

1 Like

Yes, the graphics job issue has been reported as a bug to our SDK team

1 Like