Vuforia Area Target not working in Unity (Vuforia Engine)

Hello people,

the Area Targeting feature of the Vuforia Engine simply does not seem to work.

I have recently purchased the ML2 excited to try the Basic Vuforia Features and after following the ML2 Project Setup + "Getting Started with Vuforia Engine and Magic Leap 2" on the vuforia Developer Library nothing happens when i launch the application. The application simply asks for permission to use the camera and thats it.

I created a 3D-scan using the vuforia creator app on an IPad.

After that I imported the unity package of the 3D scan in my project and inserted it to the Area Target Object. I then placed few cubes within the model.
I do see the 3D-model of my room in the unity editor.

Again, when I launch the application, nothing happens
Am I missing a critical step?

I'm using the Main Camera from Magic Leap SDK/Runtime/Tools/Prefabs/Main Camera.prefab and inserted the Components (Vuforia Behaviour (Script) and Default Initialization Error Handler (Script)).

(I've tried the Image Targeting aswell, nothing happened after launching, something lets me think the application is not using the ML2 camera)

Thanks in advance :slight_smile:


A good first step would be to download and run the Vuforia Engine Magic Leap 2 sample Unity project: Vuforia Magic Leap 2 Sample | Packs | Unity Asset Store

That includes Image targets, Model Targets, and VuMarks, and would be a good starting point to figure out what might not be working in your project.


thank you for the response.

I've come across the Vuforia Magic Leap 2 Sample Asset and tried it aswell.

I've created a unity project and finished the Magic Leap Project Setup. After that I imported the Vuforia Magic Leap 2 Sample Asset from the Unity Asset Store. After finishing the steps i receive the following errors, which makes it unable to be build.

I do see the scenes in the Build Settings however.

I hope these images help understand the problem.
Thanks again in advance for all help :slight_smile:


There seems to be a conflict happening somewhere. I heard from our team that since it looks like you first did the ML2 setup instructions and then imported the sample, that could cause conflicts. Could you try to import the ML2 sample from the asset store in a fresh project and see if that fixes the issue?



thanks for the response.

I tried importing the ML2 sample to a clean 3D Core project and it boiled down to a single error message:

Would it help to reload the magicleap.unitysdk, the files might be corrupt?
Thanks again :smiley:

Hi again,

i found the solution to the problem in one of the other threads in this forum.
Starting the Vuforia Initialization delayed was the key.
However this fix was from April 2023 so perhaps it should be further investigated.

I followed the steps of fellow user jamesashley (kudos to him! :slight_smile: )

It seems that the Vuforia Engine is not getting the permission it needs to start operating after deploying the application.

This doesn't solve the problem above with the Vuforia Magic Leap 2 Sample Project but it takes me a huge step forward in my application.

Thanks and I hope it helps more people!