Unity SDK 1.4 near clip distance

I tried following this procedure, but I systematically end up in a totally white screen whatever I do, even if I do not change anything from the SDK. I tried reinstalling, flushing the Library folder, cleaning anything, verifying XR plugin is activated... without anymore success. No exception, no error log, nothing. The application, by the way, compile and runs properly (because of the sound I hear, and the logs I see in logcat).
Just a blank screen. Even the splash screen is not visible.

Any clue what's causing this ? It seems like the display is broken.
(Unity 2022.2.10f1, ML SDK 1.4.0, ML XR Plugin 7.0.0)

1 Like

You will not need to make any changes to the core com.unity.xr.magicleap package if you are using the 7.0.0 version.

Try rebuilding your application after deleting cached package files.

  1. Close the unity editor
    2 Delete your projects Library folder.
  2. Reopen the project and wait for it to reimport. 4.Then switch the build target to Android
  3. Rebuild the application .
1 Like

This didn't work unfortunately, although renaming the package folder did the trick for me.

1 Like

I also got the white screen issue after following some of the above advice - I deleted the library folder and Unity is fixing that folder on relaunch. I was on 7.0.0pre, but did change the Packages JSON as described above as well. That got me back to the normal view, but now still clipping further out. Despite Unity UI saying I can set it to much lower clipping distance, it is defaulting back during runtime. Adjusting the package JSON is automatically updated to pre by Unity even when adjusted while Unity is closed.

1 Like

I opened -com.magicleap.unitysdk.tgz-, changed the file package.json to

"dependencies": {
"com.unity.xr.magicleap": "7.0.0",

and compressed it again with 7z as tgz.
The first time the Unity editor goes crazy,
but if you reopen it, everything works fine...

1 Like

In May update I see the following note:

Does this mean that you do NOT allow us to have less than 37cm?? For our use case we require less than that so is it still possible to turn it off??

1 Like

@jc1 Yes, that is correct. We do not allow for a clipping plane of fewer than 37 centimeters in distance.

1 Like

Hmmm. That is really a PITA. As we use handtracking in our app the people have to run around like zombies if they want to see their augmented hands. It's a shame you do not put the decision of the minimum clipping range in the hands of the developers. What will happen in the future? Plans to put it to 57 centimeters? :stuck_out_tongue_winking_eye:

1 Like

@kbabilinski @kdowney
Is there any history of how you went to the trouble of introducing support for near-clipping changes of less than 37 cm in a slightly earlier version, and then stopped allowing near-clipping changes of less than 37 cm in this update?

Repeated updates like the above make me think that the company is unstable as a developer.

I don't believe that the members of Developer Relations have any decision-making authority in this update. I believe this update is a decision made by the rest of the team.

Thank you for your valuable feedback @tokufxug. I don't have any info other than what we shared, but I have logged your feedback with our Voice of the Customer team.

I believe the change in the near clipping plane setting was requested by developers like us.
I thought the last update addressed this request.
The response was that information about the update that made it impossible to change the settings of the near clipping plane was also shared within Magic Leap.
Not only in this case, but it appears that there has been a lack of information sharing within Magic Leap since about 2021. It seems to me that a company, especially one that serves enterprise customers, lacks credibility if it cannot even be held accountable.