Remote rendering doesn't work because of windrunner

Hello, sorry for my poor English.

I am using Windows 11 and the GPU is RTX4090.

Even though I keep deleting and downloading repeatedly, windrunner-service is not installed properly.

Remote rendering runs fine on two other computers except the one I am currently using.

There is also no magic leap folder created in the registry.

What method should I try to run windrunner-service?

MagicLeap Remote Rendering version is 1.8.71

ML OS version is 1.4.1

Hello Yuna, I believe I know what is wrong here:

With this release we were guilty of a bug in our installer, which only revealed itself when an updated version of "Microsoft Visual Studio C++ Redistributable" became publicly available.

We have fixed this version in the upcoming release, which should be available soon and give you the best experience possible. If you want to use this version immediately, I can offer you two potential workarounds:

Option 1:
In your Windows settings, uninstall Microsoft Visual Studio C++ Redistributable, then rerun our installer. You can re-update Visual Studio C++ afterwards.

Option 2:
You can work around this issue, and run remote rendering without the hub. This takes a few steps in different powershell windows:

A: Run "& 'C:\Program Files\Magic Leap Remote Rendering\bin\windrunner-service.exe'" which will manually invoke our Remote Rendering service.

B: Run "& 'C:\Program Files\Magic Leap Remote Rendering\bin\setup_viewer.exe' --mode qr --mlrrc_path 'C:\Program Files\Magic Leap Remote Rendering\bin\mlrrc.exe'" while the service is active- this will generate a QR code with which you can pair your ML2 to your PC.

You will also need to manually install the Remote Rendering client via adb. This is already downloaded on you rmachine at a path similar to "C:\Users\USERNAME\MagicLeap\tools\remote_render\v1.8.71" (The specific path depends on your windows username, and where you chose to install "The Hub")

Very sorry for the trouble, I hope this helps!

2 Likes