Mesh generates "floor" or "surface" at eye level

I find that when I generate a mesh, in addition to the real floor, there is a floor-like surface also generated at eye level. I can share a project and/or video if it would help someone diagnose. This floor appears to be at the "major" tick marker in the mesh. Any suggestions on how to eliminate this?

I will try updating to see if that resolves it.

Thank you.

Unity Editor version: 2022.3.12f1
ML2 OS version: 1.4.1
Unity SDK version: 1.12.0
Host OS:MacOS

Thank you for providing details. If possible, would you mind capturing a screenshot of the issue? Also what is the mesh that you are using to generate this?




Attached is a screenshot of the issue. I've also uploaded a quick video showing the issue here: ML_20240326_09.45.18

Can you clarify your question about "what mesh" I'm using to generate this? I created the mesh based on the instructions in the Unity tutorial. (Meshing and occlusion - Unity Learn)

I've attached a screenshot of the Unity IDE in case that helps answer the question.

Thank you.

Did updating resolve this issue? And thank you for providing video. Also are you experiencing the same issue when using the example project?



I updated the Magic Leap hardware and the ML and ML Unity SDKs to the lastest. Same issue still occurs after a rebuild.

Also are you experiencing the same issue when using the example project?

No I don't experience it in the example project.

Any further suggestions would be appreciated.

Let me know if you'd like me to share this Unity Project exhibiting the issue. It appears to be 2.3GB zipped.

Assuming you are using XR Origin, look at the Tracking Origin Mode property. Device, Unspecified and Floor are the options. Set it to "device" and see if that fixes it for you.

It was already set as "Device". Thank you for the suggestion, however.

Do you mind trying to re-create your project with starting from the unity examples project. Since this seems to be a project configuration issue, it’s hard for us to determine what could be causing the offset without reproduction steps.

Any guidance on how to reproduce this issue on our end would be appreciated.

You can also double check your scene for any colitis by searching for all objects that have the collider component attached to them.

If you are not using open, XR, you can test using the ab simulator and inspect the scene hierarchy to see if there are any objects that have a collider at that height